Jump to content
Sign in to follow this  
munkittrick

Having an issue with mirroring a rig...

Recommended Posts

Hi all!
 I've modeled a few really simple stick figure-type characters and have been utilizing them to get my character rigging skills in tune for upcoming projects. This is the first time that I've experienced this exact issue, but it seems to be happening on every rig that I build. I use a fresh character rig, adjust the bones with symmetry, making certain that both the left and right side nulls are placed identically, all joints in alignment and that the model is perfectly centered to the character rig. (See attached image)

 Now, after I place the only item in the scene into the binding tab, and then move to the animate tab, the model warps to give the result that you see in the image. I've tried rebooting, reinstalling and even remodeling the admittedly simple character TWICE to rule out the possibility of an issue with the model itself.

 1.) I CANNOT get the "mirror tool" to work at all with the character rig. No matter how many time I select the bones that I want to mirror, the only thing that I get a duplicate of the entire hierarchy and NO mirroring.

2.) I cannot get my rig to bind properly, and the finger joints seems to have rolled...so that many of my fingers actually "twist" instead of curl.

  I'm freakout out, but I really need to get some kind of understanding of what's going on so that I can fix it in future rigs. I REALLY appreciate your input!

THANK YOU!!!

Rigging_Nightmare.jpg

Share this post


Link to post
Share on other sites

Hi

 

I'm on my phone right now but if you can upload the file that will help,  il have a look today.  Is your character facing negative z or positive?

 

Dan

Share this post


Link to post
Share on other sites

Hi, looking at your top screen shoot in the adjust mode, you don't have the symmetry checked.

Also i might be wrong but i don't think you can use the joint "mirror tool"  on a character object rig.

Share this post


Link to post
Share on other sites

Nope you cant use joint mirror tool, thats for custom made rigs.  All mirror activities needs to be done within the character builder.  I cant zoon in on them pics close enough to see on my phone. Im just making a quick video just to run through the steps to see if you missed anything.

 

Dan

Share this post


Link to post
Share on other sites
1 minute ago, Rectro said:

I cant zoon in on them pics close enough to see on my phone.

Hi Dan, his character is facing the z- and is centred.

Share this post


Link to post
Share on other sites
20 minutes ago, digitvisions said:

Hi Dan, his character is facing the z- and is centred.

Thanks, hard to see on my phone.  Good pick up on the mirror tool, I think all his issues are around that, and the fact that he is not having symmetry check on for character builder.  Iv shown this in a quick video posting in a min.  

PS: Just in case your not already doing this, to create limbs for both sides as you build it, hold Shift key to stay in that modular build stage, and Shift + Ctrl to both stay in that stage and add limb joints in symmetry.  It would seem your building one side then trying to use the Joint mirror tool.

Dan

Share this post


Link to post
Share on other sites

Dan, you need a larger phone.😀

Share this post


Link to post
Share on other sites

I remember a similar issue with the feet moving out of line after bind command and moving back on adjust command.

Share this post


Link to post
Share on other sites
9 minutes ago, digitvisions said:

Dan, you need a larger phone.😀

Yea I certainly do, although mine fits in my pocket, it seems phones these days are getting towards the size of tablets.😊

Share this post


Link to post
Share on other sites
  • Topic Author
  • Hi gentlemen. My apologies for the delay. I'm in the US and do not get alerts from the forums at all, for some reason.

    1.) The model is -Z and is centered in the workspace.

    2.) It is, in fact a character rig from the built-in character tools in C4D.

    3.) I built everything with symmetry ON, but found, upon clicking the binding tab and then the animate tab that the right hand seemed to rotate at one joint or another, so I made a copy of the project and tried to get the rotation of the joints correct independently....which resulted in absolutely no change.

    4.) It was my initial thought that the models might have inverted normals or even an odd number of polys, but after checking, and rebuilding the character rig from the ground up, I get the exact same result. One thing that I noticed with the character rig...when I assemble the joints in the "build" mode, and then align them in "adjust" mode...the finger nulls DO NOT move, just the bones/joints children move. I need to view the entire hierarchy to recenter the fingers so that they don't have any odd axis misalignment. Occasionally, I'll find that ONE joint will have a 180 degree out-of-phase bone...but regardless of fixing the rotation or not, the result appears to be the same.

     Essentially, I'm trying to use the character rig for some very rudimentary animation. I'm not doing any animation to rhythm or matching voice tracks. The character rig has proven to be a great one-shot tool to get this done, but with this new hitch, if you will in the system, I can't get the joints to act as they would in a natural, real-world character.

    Thank so very much for your time. I do appreciate it.

    Share this post


    Link to post
    Share on other sites

    Can you send the scene file please, Im sure its something simple missed in the moment of frustration.

     

    Dan

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • Certainly.  It's a mid-poly build that is at the bare minimum for the model without going into creating Normal maps and deformations...but it's attached for your interest.

    Thanks again!

    Mid_Poly_Rig_Test.c4d

    Share this post


    Link to post
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    Sign in to follow this  

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×
    ×
    • Create New...