Jump to content

Sign in to follow this  
howie

Effectors and stretched bevels

Recommended Posts

If I wan to change the height if a primative object, which has a bevel, using an effector, the bevel stretches. Is there a way around that so the bevel doesn't stretch?

Share this post


Link to post
Share on other sites

You could do it using the bevel deformer after the clone scale like my file below. which works for a few clones but the geo will add up quickly. so if you needed to use instances then this might not be the way to go..

I would imagine its possible with some xpresso to drive the height parameter of the primitive with an effector. That would be a far more elegant way to do it, but beyond my skills I m afraid. Hopefully one of the other members might have that solution for you.

 

Deck

 

Screen Shot 2019-11-26 at 10.26.17.png

Bevel after scale.c4d

Share this post


Link to post
Share on other sites
  • Topic Author
  • Hey Deck. I tried with a bevel deformer but that was stretching too. How have you set that up?

    Share this post


    Link to post
    Share on other sites

    You can also use clone blending for that. Just provide the min an max height version of your primitive, set the cloner to blend mode and the "Modify Clone" in the parameter tab of your effector to 100%. I've attached an example. 

    Clone_Blending.c4d

    Share this post


    Link to post
    Share on other sites

    Theres a file in the above post under the screen grab. Havealots option could be a better way to go.

     

    Deck

     

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • Sorry Deck, I didnt notice that. That works well. As always, stick it in a connect object, don't know why I didn't try that. 

     

    Havealot, good solution too, nice one. 

    Share this post


    Link to post
    Share on other sites

    I think it will work without the connect ( grab below ), I threw it in for safety as the phong was looking a bit weird on my machine, I think I left it on solid instead of chamfer.

     

    Deck

     

    Screen Shot 2019-11-26 at 11.55.36.png

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • interestingly that's not happening on mine. What version are you running?

    Share this post


    Link to post
    Share on other sites

    Ah, you're right, now I look closer and stretch it a bit more, it is scaling the bevel also when in just the null, but works as expected inside the connect.

     

    Should have gone with my first thoughts 🙂

     

    Deck

    Screen Shot 2019-11-26 at 12.47.37.png

    Share this post


    Link to post
    Share on other sites

    To solve that is needed apply bevel on whole connected hierarchy. Like in this picture

    uniform_bevel_pict.thumb.png.04d311c27e0aac763f8ac72b5e566ae7.png

    scene file:

    uniform _bevel.zip

    Share this post


    Link to post
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    Sign in to follow this  

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×
    ×
    • Create New...