Jump to content

Sign in to follow this  
Smolak

Hide visible polygon edges, outlines ?

Recommended Posts

Is there any way to hide these blue polygon edges, outlines while editing in polygon or point mode ? If I have dense geometry there is impossible to see anything while editing. I want to have clear view like it is in object mode or make these outlines less visible, transparent. Is this possible like it is in other software ? Maybe plugin ?

 

image.thumb.png.e6321b8ab66d6c5d3e68282528055ac8.png

Share this post


Link to post

You can't turn them off whilst editing AFAIK, but you can edit the colour scheme to make them less intrusive when unselected...

 

image.png

 

 

Or if you are using subdivision, then changing from wireframe to isolines, and enabling isoline editing can help.

 

Maybe someone like @bezo knows of a plugin that will do it but I haven't come across one that I remember...

 

CBR

Share this post


Link to post
6 hours ago, Smolak said:

Is there any way to hide these blue polygon edges, outlines while editing in polygon or point mode ? If I have dense geometry there is impossible to see anything while editing. I want to have clear view like it is in object mode or make these outlines less visible, transparent.

 

 

I do have some script/plugin that might help, but before I suggest any I would like to really understand what you need. What do you need to show, what do you need to hide?

I understand that the dense geometry inhibits a clear view. But if you switch off polygon edges how are you able to select points or polygons if there is nothing to indicate where polygons or points are? How are you able to edit anything, if what you want to edit isn't visually defined? It would be as if blindfolded picking points and polygons, would it not?

So, please explain how you would want the clutter of polygon edges to be shown or hidden, and still allow you to edit them?

Share this post


Link to post
  • Topic Author
  • I worked this way in LightWave for many years. In orthagonal views I had visible wireframes but they were much less visible than in Cinema. When object is zoomed out they are way too bold. They cover all visible object detail. There should be setting to make them less pronounced, more thin or transparent. In perspective view I had OGL view without visible polygons wires. So I can move selected polygons or use brush with falloff to edit them and in perspective view I see whole clear object without lines. In Cinema 4D there is no way to have orthagonal views with wires and perspective without them while editing in polygon mode.

     

    Example :

     

    image.thumb.png.edb22f910285570af4f4e37db2d96ec6.png

    Share this post


    Link to post
    57 minutes ago, Smolak said:

    ... have orthagonal views with wires and perspective without them while editing in polygon mode.

     

    Ok, now I understand what you mean.  Unfortunately, I have no solution for that. Sorry!

     

    Share this post


    Link to post
  • Topic Author
  • Anyway thank you all for information. Maybe there is some official MAXON feature request form ? At the moment I'm using Octane Viewer as perspective viewport for such things 🙂

    Share this post


    Link to post
    2 hours ago, Smolak said:

    Maybe there is some official MAXON feature request form ?

    Yes there is, but it moved recently. It's now a category under Support ticket on support.maxon.net

     

    CBR

    Share this post


    Link to post

    Personaly I´m using IRR with smaller resolution, but also MagicPreview plugin is very helpful. While Lazaros´s plugin is locked to "Use as Render View" command, IRR in new view panel docked somewhere in interface use own camera, so you could adjust view as you want (it will keep position of camera) and work with model in some orthogonal view in different camera position/parameter etc...

    735718961_previewwithoutgeometry.thumb.png.82e03b93e701d97de8cef2b816393c30.png

    Share this post


    Link to post

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    Sign in to follow this  

    • Recently Browsing   0 members

      No registered users viewing this page.

    Latest Topics

    Latest Comments

    ×
    ×
    • Create New...