Jump to content

Sign in to follow this  
tdtd

Mograph Cache Tag Issue/Glitch

Recommended Posts

Hi,

 

I'm experiencing something very strange with the mograph cache tag. This issue only started today - all was working fine earlier.

 

Basically as soon as I use the mograph cache tag it seems to ignores the dynamics.

However if I use the cache while at any frame other than 0 and scrub the timeline, I can see the cache tag worked. However as soon as I go back to frame 0 it resets.

 

This is driving me crazy, would really appreciate any help. I've attached the test scene.

 

Thanks very much in advance.

Tom

test.c4d

Share this post


Link to post

You are caching the wrong thing as far as I can see. If you go into the dynamics tags / cache, and do Bake All, you get a cache with everything in it, that works for me in R21...

 

CBR

Share this post


Link to post
  • Topic Author
  • 12 minutes ago, Cerbera said:

    You are caching the wrong thing as far as I can see. If you go into the dynamics tags / cache, and do Bake All, you get a cache with everything in it, that works for me in R21...

     

    CBR

    Hi,

     

    Thanks for your quick response.

     

    Yes the dynamics tag lets me bake it and works fine. However the advantage of the mograph tag is that I can then copy this into another document and keep the cached frames. This has always worked for me before with dynamics included so not sure what's changed?

     

    Thanks again,

    Tom

    Share this post


    Link to post

    Hmm. I'd have to disagree with you there - the Mograph cache only records movement caused by effectors, and I am fairly sure it has always been that way...

    The manual and my own tests in R19 both confirm this. If you load this scene into one of your previous versions does it work there for you ? Cause I'm gonna bet it won't...

     

    CBR

    Share this post


    Link to post
    On 1/5/2020 at 7:32 PM, Cerbera said:

    Hmm. I'd have to disagree with you there - the Mograph cache only records movement caused by effectors, and I am fairly sure it has always been that way...

    The manual and my own tests in R19 both confirm this. If you load this scene into one of your previous versions does it work there for you ? Cause I'm gonna bet it won't...

     

    CBR

     

    Not sure what you do differently, but it's working for me. 

    MoCache_dynamics.c4d

    Share this post


    Link to post
    52 minutes ago, Havealot said:

    Not sure what you do differently, but it's working for me. 

     

    Yep, that seems to work, and also with softbodies so I stand corrected there - thanks.

    We could probably correct the manual which could make clearer that this works with more than effectors, although now I look again, I see there is a dynamic tag in the example picture that goes along with that, which I apparently missed the first time I looked ! 🙂

     

    Did you load OP's file at all ? That was the one I tested in R19 and R21, and couldn't get the Mograph cache tag to register the softbody movement...

     

    CBR

     

    Share this post


    Link to post

    Hey Cerbera, 


    you are right, I didn't try on the original OP file. I was just challenging your statement that MoGraph caches only record effectors. Not a solution for the OPs problem. Maybe I should have pointed out. Softbodies deform the object itself and as far as I know point deformation is not stored in MoGraph caches. 

    Cheers;
    Havealot

    Share this post


    Link to post

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    Sign in to follow this  

    • Recently Browsing   0 members

      No registered users viewing this page.

    Latest Topics

    Latest Comments

    ×
    ×
    • Create New...