Jump to content

Inverted UV islands?


Recommended Posts

I downloaded your last file Platinic, and exported as FBX and imported back into C4D, the Uvs are fine, they dont show black.  Projecting is working as expected, and Im not getting inverted Uvs in Unfold3D from a exported obj but further tests show these dont show anyway in either C4D or Unfold3D. 

 

 Exporting your file as FBX from r21 or r20 does have that inverted normal as seen in Modo.  Running the Align Normals did not fix it.  I unfolded your scene file manually and there was again flipped Uvs normals.  using your scene file I manuals unfolded with my own seam selection and normals are showing wrong in MODO, maybe there is something iv not got turned on in C4D to show them?

 

Now when I make my own Platonic file in C4D and use wizard or manually unfold it and it exports fine and shows fine in MODO.  There is something up with your file.  Next test is to export your obj and unfold it in Modo.

 

TEST 2:

With your file I unfolded in Unfold3d Uvs tested fine in MODO and C4D.  Exporting this file from C4D r21 as FBX was also showing fine.  Very odd.

 

Summery:

Your file platonic object exported as FBX or Obj in r21 or r21 showed reverse UV normals.  Unfolding either from wizard or manual seams on your file yielded the same bad results.

 

Again your file exported as a OBJ and unwraped within Unfold3D worked file without any issues.

 

My Platonic file worked fine with Wizard, or manual Unfold in C4D.

 

Dan

 

 

Link to post

Thanks @bezo , for clarifying the .022 issue, and yeah I have the Adobe CC suite.

It is so confusing, I updated again to .115, restarted, and the problem still exists.

@Rectro thanks for trying the c4d file, could you try importing the FBX from the zip file into Rizom directly and see if the exists?

This problem is affecting my 3D scan texture workflow, since I unwrap uv in Cinema, export FBX, and build texture in Metashap. If all my process happens to be in Cinema 4D, I don't notice this issue.

Same (problematic) FBX, works just fins in Substance Painter 🤔

 

Link to post
12 minutes ago, foxtuon said:

Thanks @bezo , for clarifying the .022 issue, and yeah I have the Adobe CC suite.

It is so confusing, I updated again to .115, restarted, and the problem still exists.

@Rectro thanks for trying the c4d file, could you try importing the FBX from the zip file into Rizom directly and see if the exists?

This problem is affecting my 3D scan texture workflow, since I unwrap uv in Cinema, export FBX, and build texture in Metashap. If all my process happens to be in Cinema 4D, I don't notice this issue.

Same (problematic) FBX, works just fins in Substance Painter 🤔

 

I updated my tests.  I dont have Rizom I have Unfold3D which only imports OBJ.  As in my test your Platonic file contained the issue in OBJ files as well as FBX when viewed in MODO. When I produce a Platonic from scratch and Unfold in C4D all is fine.  When I use your file as a OBJ within Unfold3D and use your same seams but perform a unwrap  guess what, it fixes your file.  I Used Wizard on your file and Uvs tested good.  I ran a manual seam unfold on your file and seams showed good.

 

I will ponder on this some more and have another look tomorrow.

 

Dan

new test.jpg

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...