Jump to content

Sign in to follow this  
charkakashi

Object buffer laptop screen replacement

Recommended Posts

Hi all, I need some advice!

 

I followed the SOM phone animation tutorial this all made sense and have spent a lot of time going through it, this includes: multi-passes, Global illumination, ambient occlusion, object buffers, compositing tags, external compositing tags, etc. This went well meaning I could track a null into after effects using CineWare and replace the screen using a luma matte on the phone screen and parenting to get the video I required on the screen without too much trouble (now I understand it). 

 

Assuming theoretically that this would also work the same for a laptop spinning in cinema 4d, then the screen flipping up revealing a video on the screen. Unfortunately this is not the case, having tried and tried the proportions are off. The null moves in the same way as the laptop screen revealing itself at the right time when the screen flips open, its as if the axis centre is not matching up with the laptop screen and thus rotates at a different speed??? 

 

This message is a bit confusing as I am confused!!! Has this happened to anyone else??? If anyone could shed my light on this issue that would be great, pulling my hair out  at the mo and close to giving up. Im thinking it has something to do with object centre axis, where the hinge flips up its from the bottom and not the centre of the screen. Or could be something to do with the parenting within parenting???

 

Any help would be greatly appreciated thanks!!!

image.png.23d2296606167b018b91791f98915a44.png

image.png.619bc4eccbced52d3a7b927cbaba7e53.png   

image.png.af20955be32c50a97913a49fe2009eed.png

image.thumb.png.54ef4d932a45fcdf39bb7fe0a2b6241e.png

Share this post


Link to post

There are 2 things you could check.

If you're rendering an image sequnce from C4D, check that AE is importing image sequnces at the same frame rate, for instance, if your render is set to 25fps,

Make sure AE imports the image sequence at 25fps. I think the setting is in the AE preferences, or right click the footage in the AE Project window and select Intererate Footage. 

 

The other thing to try is to centre the axis to the plane in C4D. The axis point in AE is always different, but as long as the frame rates are the same, the movement should match, but most of the time you'll need to re-adjust the position/scale of the replacement image in AE to fit the screen size correctly.

 

Hope this helps.

 

 

Edited by southpaw
typing mistakes

Share this post


Link to post

There are several steps to get this effect working, so don't be put off if you mess up the first time. With this technique, you do NOT need to do any tracking or even corner pinning.

 

While I don't fully get what you tried, if I was tasked with being able to easily replace those screens in After Effects, you would need to use an External Compositing tag in addition to the Object Buffer on the screen object. I believe you can name this tag so you know what it is in AE. The External tag will give you a 3D layer when you bring into AE. This next part used to confuse me, but I get it now. This 3D layer is only for the data and not what you see of that layer, which will probably show up as a red box that follows the motion, but isn't the right size of your screen. This is fine.

 

So in AE, you need to create your two comps, Screen 1 with what's on the first screen and Screen 2 with what is revealed. Make the content in these comps take up the entire comp size and make all the layers 3D.

 

In your main AE comp with the rendered animation, select that red box layer (compositing tag) and select the comp with Screen 1. Holding the Option key, drag the Screen 1 comp onto Red Box layer in the timeline. Boom. Your Screen 1 comp is now using the 3D data from C4D. Scrub to see it moves correctly. Now scale you layer down the right size. Drop you Object Buffer mask on top and set it to Luma Matte. Magic

 

From here you need to work through AE stuff and clip layers when you need to, and stack things correctly. The best thing about this technique is that, from this point on,  when you need new info on those screens, you just double-click the comps and you can edit them in flat, 2D. You can put ANYTHING in Comps Screen 1 and Screen 2 and they will fit perfectly every time.

 

MAKE SURE YOUR ANIMATION AND YOUR AE COMPS ARE ALL THE SAME FPS! I made that mistake before, and it drove me nuts until I figured it out.

 

If you're still confused, or if I misunderstood what you're trying to do, post back.

Share this post


Link to post

Big Al your the man, 

 

Thanks for taking the time to write out a thorough walkthrough, yes I know the pain of a frame mismatch fixed that issue on Friday!!! Seems to me like I'm running into constant problems, but I'm new at C4D and it's so interesting to me!!!

 

I made a simpler version to see if I could get it to work, one of the issues was that the model axis were not lined up correctly, as well as this the null is absolutely huge, going off the screen in AE so it was hard to see where I was going wrong. Il attach a screenshot below, any ideas on how to make the null fit within the screen I'm trying to replace?

 

image.thumb.png.e6bbcfc98b8d73830e6907200577b140.png

 

 

 

Share this post


Link to post

To get a smaller null/solid in AE, select the External Compositing tag in C4D's Object Manager, then in the Attrubues Manager, enable the tickbox that says "Solid", you'll then see the size fileds enabled, you can enter a custom size there, try a smal number like 10 for example, that way, when you open in AE you'll get a smaller Null/Solid to work with.

 

Share this post


Link to post

Like I said, the size of the Compositing Tag object is irrelevant in the long run. It's just the 3D data that you're using. I'm a little confused when you say Null, but maybe its what @southpaw mentioned about the Solid setting. After dragging your replacement comp, you shouldn't see the outline of that huge layer anymore. Your comp will replace that layer entirely. I forgot to mention earlier, once you drag and replace, you can then dupe this new layer and drag your second comp on it to replace. You can also dupe the original and turn it off for future use as well.

 

If you do put dimensions in there, just put something on the small side. Like I said, it doesn't matter at all. 

 

It's a lot of setup, but once it's done, you can crank out different version from AE in minutes.

 

Here's an example I did in the past. I was able to drop new screens behind the car and gifts with ease.
https://vimeo.com/tier10studios/review/308307511/1ceae244b5

 

Edited by BigAl3D
Added Vimeo example

Share this post


Link to post

Hi guys,

Thanks for the replies its really helped consolidate my knowledge 🙂

Now i've looked at the issue in more detail I can understand what is actually going wrong, the null is tracking the laptop perfectly in some aspects: image.thumb.png.93859d21ae8892ed9fec2de9913a1251.png 

 

When it comes to the movement of the base, but when I open the laptop using hinge controls, the null does not follow the laptop opening. Even though I have set the object buffer to be on the top face of the laptop where the screen is... in C4D it shows the null moving appropriately but when importing to AE it only does half of the movements (without the screen opening at the end and turning 90 degrees)

 

Share this post


Link to post

Well, at this point, I'd have to see the C4D file myself. If you can't post it here, you can PM me a link. Either way.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...