Jump to content

Sign in to follow this  
bluedream

C MOTION ANIMATION ERRORS AFTER BAKING

Recommended Posts

hello, first time posting on this site. I have a robot rig working like I want in C motion but when I bake to keyframes the rotation on both knees is messing up. I tried manually keying where it goes wrong but when replaying the animation it goes back to how it was? I tried deleting C motion but the same thing is happening. Any help with this would be greatly appreciated!

 

Share this post


Link to post

Hi

 

Can you please provide the file pre baked.  It could be a number of things like a IK poll in a bad place.

 

Dan

Share this post


Link to post

Hi

 

I think your issue is in the method you used to bake it, can you tell me the procedure you used?

My results turned out fine, here is what I did.

 

1:  Select Character object, in Display tab under Managers change it to (Components)

2: Use the Animation layout and make sure your in the Dope Sheet and that in View menu Automatic is turned off,  this effects whats seen in the Dope Sheet.

3:  Drag from the object manager the following into the Dope Sheet. Root, Spine, plus all Leg and Arm components.  Your now see a long list in the Dope Sheet.

4: Select everything in Dope SHeet Ctrl + A.  Then in the Functions menu choose Bake.  Turn Copy off in the Bake options, press Bake button.

5:  You can now delete Cmotion if you wish or turn it off.

 

PS: Keep in mind that if you wish to export it as a FBX your need to bake this data into the joints, the controllers will be ignored.

 

Dan

Share this post


Link to post
  • Topic Author
  • Hey @Rectrothank you so much your a damn wizard lol. a little confused though, when i drag the root, spine, and leg and arm components from the object manager into the dope sheet i dont see a list just a summary folder that looks like theres nothing in it and boke options in functions is grayed out. sorry im sure its frusterating trying to explain this to a complete idiot lol. first time doing this without mixamo 

     

    Screen Shot 2020-01-21 at 7.42.10 AM.png

    Share this post


    Link to post
  • Topic Author
  • and when i baked it the first time i just selected the "fixed legs" null in the object manager then selected add motion clip.. from the animate tab  @Rectro it converts to a motion clip and everything is still working and then when i convert layer to a keyframe animation everything gets jacked up. Thanks again dude!

    Screen Shot 2020-01-21 at 8.01.57 AM.png

    Share this post


    Link to post

    Hi

     

    Im put it into a video for you, its much easier sometimes to see it.

     

    Dan

    Share this post


    Link to post
  • Topic Author
  • Thank you!

    Share this post


    Link to post

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    Sign in to follow this  

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×
    ×
    • Create New...