Jump to content

Sign in to follow this  

Cinema 4D Arnold Alpha Mask

Recommended Posts

I'm trying to create a shader that has a transparent area using an alpha mask. I can't get it to work. I used the Cloth tag. Please help me!


Link to the working C4D file: https://www.dropbox.com/s/b2d0cu4h97t7b7r/AlphaMap.zip?dl=0



Share this post

Link to post

Unfortunately, to be able to help you, one will have to have Arnold. I am not sure how many people actually using it here. Did you try on one of the Arnold forums?

| MAXON Quality Assurance Specialist | 3D Asset Creator | C4D Cafe Manager |

Share this post

Link to post

To use an alpha mask in a texture, you need to do the following:


1. Create an additional "image" node, and place the alpha texture in there. Then, connect that new image node to the input of the standard shader, and connect it to: Main - Geometry - Cutout Opacity.


2. Right click on your object and add an Arnold Parameter tag and disable the "opaque" option.


3. Click on the material tag and enable, "tiling". You had tiling turned off, and it needs to be enabled. This could be a bug. Not sure.


4. Your alpha texture was inverted vertically. So, I had to open it up in Photoshop and flip it. Make sure all of your textures are oriented correctly.


Everything should be good now!

arnold alpha.jpg

Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...