Jump to content

Sign in to follow this  
Mirza Kadic

Luma Matte problem

Recommended Posts

Hi everyone!

 

I'm trying to solve a problem for few days now, and I have quite some experience with After Effects, C4D, Redshift etc.. But this I just cannot figure out, and it's kinda basic stuff

 

So, I'm selling video renders for a marketplace and for that reason I need 2 files in zip package, one beauty pass and another black & white luma matte (for users to combine the two to get alpha channel).


For example...
Beauty (with post fx applied - bloom,glare etc.):

 

beuty.jpg

Luma matte (combined post fx and with alpha channel to get this luma matte):

lumamatte.jpg

But, when I use beauty and set track matte in ae with luma matte (example above), it does make an alpha, but a lot of information kinda disappears, notice the glow/bloom is almost not present (image does have an alpha channel, but showed it with black BG to show what I mean)

 

combined.jpg

Of course, I tried to brighten luma matte, but then I get this:

spil.jpg

I'm getting grey hair as we speak, so any insight would be really appreciated!

Share this post


Link to post

Are you comping in 32bit within AE?

Additionally, you could try applying a colour correction/curves, chooosing Alpha in the Curves dialogue and increasing the mid-tones.

 

 

Share this post


Link to post
  • Topic Author
  • 17 minutes ago, southpaw said:

    Are you comping in 32bit within AE?

    Additionally, you could try applying a colour correction/curves, chooosing Alpha in the Curves dialogue and increasing the mid-tones.

     

     

    32 yes. Regarding color correction I wrote:

    Quote

    Of course, I tried to brighten luma matte, but then I get this:

     

    Share this post


    Link to post

    Apologies, I didn't catch the sentence about colour correction.

    Have you tried rendering both a Straight Alpha and Pre-Multiplied Alpha and testing those as Luma Mattes?

     

    I don't see a mention of the file type you're rendering to.

    Are you rendering Linear 32Bit TIFF,  EXR or similar? If not, that might be the issue.

    Have you double checked that AE is set to sRGB and Linearize Colour Space is checked in the project settings?

    Other than that, I've no idea why this is happening.

    Share this post


    Link to post
  • Topic Author
  • 2 hours ago, southpaw said:

    Apologies, I didn't catch the sentence about colour correction.

    Have you tried rendering both a Straight Alpha and Pre-Multiplied Alpha and testing those as Luma Mattes?

     

    I don't see a mention of the file type you're rendering to.

    Are you rendering Linear 32Bit TIFF,  EXR or similar? If not, that might be the issue.

    Have you double checked that AE is set to sRGB and Linearize Colour Space is checked in the project settings?

    Other than that, I've no idea why this is happening.

    I did everything you mention. 32 bit tiff, ae is set to srgb and linearize, even from c4d I set up linear workflow, nothing seems to work, or I'm missing some step here....

    Share this post


    Link to post

    The only thing I can think of is that things like Bloom and glows are usually a post effect in the 3D renderers I've used, and this may be what's causing the loss of data.

     

    The best solution I can think of would be to add blooms/glows etc in AE, and render an Alpha from there. Then re-imort the rendered alpha for use as a luma matte.

    Share this post


    Link to post

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    Sign in to follow this  

    • Recently Browsing   0 members

      No registered users viewing this page.

    Latest Topics

    Latest Comments

    ×
    ×
    • Create New...