Jump to content

Textures on xpresso objects


Recommended Posts

Hello all, any help appreciated,

have a project with sqaure textured pillars, each pillar has 2 expresso sliders, one to operate position, the other to effect its height, 

the texture most stay the same height and NOT compress when you change the objects height, have done that by placing the textures on a null as a parent of the pillar,

so thats all working... however when i change the position the texture does not stick with it... as its flat projection.....

is there a way to achieve both?

LANTERN TEST.zip

Edited by Cerbera
Fixed typos in keywords
Link to post

If we cheat then yes, but otherwise no I think, or at least not with your current material setup.

 

I would get the pillar in a boole with a tall cube as Operand B (subtraction), and instead of your scale slider controlling the Y scale of the pillar, make it control the Y position of the subtracting cube instead. This will do effectively the same thing as your original plan, and allow you to move it all about with the texture going with it.

 

CBR

Link to post

Problem is caused by user ;-) , and it´s called "naming" (itself it´s not a problem, it´s just "source" of following problems :-) )

The one of main rules (especially with some xpresso/code setups) is creating unique name for every object.

When you look in your scene, you have three different object with the same name. Polyobject driven by part of xpresso has not assigned materials, so that´s the reason why when you moved with polyobject textures don´t change position with polyobject, so need to be driven other object.

 

assigned_objects.thumb.png.eaafd2d8a1070fba9b6151926fd0dcc0.png

 

 

 

 

 

Link to post

Thank you Cerbera, appreciate the reply.. frustrating, the texture if for a team to create content too knowing where the sides join etc,

have just seen you next comment, cunning thank you will try that now

 

Link to post
11 hours ago, Cerbera said:

If we cheat then yes, but otherwise no I think, or at least not with your current material setup.

 

I would get the pillar in a boole with a tall cube as Operand B (subtraction), and instead of your scale slider controlling the Y scale of the pillar, make it control the Y position of the subtracting cube instead. This will do effectively the same thing as your original plan, and allow you to move it all about with the texture going with it.

 

CBR

 

11 hours ago, bezo said:

Problem is caused by user 😉 , and it´s called "naming" (itself it´s not a problem, it´s just "source" of following problems 🙂 )

The one of main rules (especially with some xpresso/code setups) is creating unique name for every object.

When you look in your scene, you have three different object with the same name. Polyobject driven by part of xpresso has not assigned materials, so that´s the reason why when you moved with polyobject textures don´t change position with polyobject, so need to be driven other object.

 

thank you, really appreciate your time ! i should stick to production and stop pretending i can drive cinema... 

thank you again

 

 

assigned_objects.thumb.png.eaafd2d8a1070fba9b6151926fd0dcc0.png

 

 

 

 

 

 

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...