Jump to content

Sign in to follow this  
EnriqueShockwave

Make Preview not rendering gouraud shading

Recommended Posts

Hey there C4D friends, 

 

Quick question here. In previous versions of my scene file, I was able to make a preview (alt+b) using the Software Open GL preview successfully to get an idea of the timing of my animation. It rendered out what I saw in the viewport with shading and image textures (see image attached which is just a screenshot of my viewport currently). But now, when I make a preview, Im just seeing the Lines of my geometry (see other image attached). Im able to switch between gouraud shading and lines in the viewport, but it seems like I dont have that option with make preview and Im just getting lines. Can anyone shed some light on this? Scratching my head over here. 

 

Thanks! 

 

(Running R20 on my Macbook Pro)

 

Screen Shot 2020-02-17 at 10.21.41 AM.png

Screen Shot 2020-02-17 at 10.21.24 AM.png

Share this post


Link to post

Instead of "make Preview" you can use the Hardware option in the render settings menu. I use it all the time, it's great.

Share this post


Link to post
  • Topic Author
  • Thanks so much for replying DasFrodo. 

    By that do you mean, render out a sequence using the hardware renderer? Thing is, I want to make a preview in the picture viewer. Would you mind elaborating on your method?

    Share this post


    Link to post

    There's not much to elaborate on ! In Render Settings change Render Engine to Hardware Open GL, and set the options you want, then set your output size, frame range etc in the output settings then press Render to Picture viewer !

     

    CBR

    Share this post


    Link to post
  • Topic Author
  • Hi Cerbera, 

     

    The problem is that I've done that and the picture viewer is showing only a wireframe/line render, not a shaded one like I see in my viewport! In previous versions of my scene files the make preview option works perfectly, but I must have pressed something or switched something and now the picture viewer is only showing me a line render. What do you think I could have done? Rippin my hair out over here! 

    Share this post


    Link to post

    Can you post small part of scene for checking?

    Share this post


    Link to post
  • Topic Author
  • For sure Bezo. Ive attached it here.

    Ive stripped the file down a tonne and its still rendering with only lines.

    Any and all help would be great! 

    SceneFile_Cafe.c4d

    Share this post


    Link to post

    Ok that took a little while to solve, but solved it is...

     

    image.png.011bd82bf14b5b300a9f5db89b764fbe.png

     

    For some reason you didn't have the Perspective View selected as the Render View, and because of your custom layout, which didn't show you the view that was actually rendering you couldn't see that it was a wireframe orthographic view, hence the result you were getting. 

     

    So, in the view menu of the perspective viewport, find the 'Use as Render View' option 1 from the bottom, and click that...

     

    You also don't have a phong tag on your snake head, which is why it looks all jaggy and faceted like that. Add that from the Render Tags section to get a properly smoothed result like mine above...

     

    CBR

    Share this post


    Link to post

    So why didn't the body appear in my render above ? That was an order of operation thing. Cinema scans the Object manager from top to bottom, and the spline that was driving your spline wrap was below the object referencing it, so that explains that error, which is fixable by simply moving the spline to where it should be - anywhere ABOVE the spline wrap in the hierarchy...

     

    image.thumb.png.714cc5105db45ad7a7d40e721f03e8d5.png

     

    CBR

    Share this post


    Link to post
  • Topic Author
  • Cerbera, 

     

    THANK YOU. The camera issue was driving me nuts too so not only did you solve my main problem, you solved another one that I didnt even mention. I have no clue how I even had this custom layout - it must have been an accident. Either way, I REALLY appreciate your help. This is my first post on C4D Cafe and Im really impressed with how fast this was answered. You guys rock 😀

     

    Cheers! 

    Share this post


    Link to post

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    Sign in to follow this  

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×
    ×
    • Create New...