Jump to content

Lights in Alpha Channel Error


Recommended Posts

Hello! I'm trying to export an ProRender image with an Alpha Channel, but in the Alpha Channel, its registering the PBR light. Essentially I have a huge PBR light scaled up between these fractal blocks. If you were to composite Image 1 in After Effects, you'll see that the top of the image ins't transparent, because that's where the light is. 

For PBR, I went to Details and checked off "Show in Render" & "Show as Solid in Viewport", nothing.

Is this a glitch? It's not showing up in the Main Render itself...but it is showing up in the Multi-Pass Settings as well. On Image 2 is the Ambient Occlusion, and the top

of the image is only showing the giant blank square [the light], and not the shadows of the cubes, like on the bottom part of the image.

 

I took out the Light in Image 3, and as you can see [if you were to composite it], the top part will be transparent where the black gaps are.

 

Anyone have any guesses as to how I can fix this? ANy help would do.

Best,

Kenny

Image 1.png

Image 2.png

Image 3.png

Link to post

  • Community Staff

Alright, this might just be one of those things that ProRender just can't do 🙄

I tried it with your file and an own file, just to make sure there is no setting you changed that I don't know of. Can't get it working, not even with Object Group ID buffers...

There just MIGHT still be a way, but I can't find it, sorry.

Visit my Portfolio on Artstation.com & Follow me on Instagram

Link to post

15 hours ago, DasFrodo said:

Alright, this might just be one of those things that ProRender just can't do 🙄

I tried it with your file and an own file, just to make sure there is no setting you changed that I don't know of. Can't get it working, not even with Object Group ID buffers...

There just MIGHT still be a way, but I can't find it, sorry.

 

No apology necessary, I'll try to report this to MAXON, maybe in a future update this can be addressed. Thank you for taking the time and working on it, I really appreciate it!

 

Best,

 

Budda

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

ABOUT US

We are dedicated Cinema 4D Community of friendly and passionate artists, hobbyists and developers. Feel free to join us and share your knowledge, your art and anything that might help Community to grow. We are providing guidance, free plugins and files, feedback, sponsorships and various discounts for our Contributors. :cowboypistol:

SUPPORT

Tickets

Purchases

×
×
  • Create New...

Copyright C4D Cafe © 2020 Powered by Invision Community