Jump to content
Sign in to follow this  
Flonoel

Voroni Fracture with Dynamic tags won't collide

Recommended Posts

Hi Guys, 

 

I hope you're all well! I'm new to the forum. 

 

I have a fairly simple scene set-up with a very frustrating problem: 

I want to create an area of stones floating in the air, then (at frame 500) the stones are being blasted away by some sort of shockwave. 

 

For the stones I used a cube with voroni-fracture, a push apart and a random effector to give some movement. For the blast I took this as reference: 

 

 

So a sphere with expanding radius in the middle of the stone field. Collider body tag on the sphere, Rigid Body Tag on the Voroni. In the general settings I've put the gravity to 0 so the stones won't instantly fall down. 

 

Problem: 

 

In the viewport the dynamics look fine (most of the times, when rigid body put to immediately) but when I either render the dynamics, bake it or put the rigid tag to "on collision", the sphere only hits a very small amount of floating stones. 90% of the stones are not being effected at all. 

 

Any ideas? 

 

Thanks a lot in advance! 

 

ExplosionStones.c4d

Share this post


Link to post

Hi Flonoel,

 

the setting that is preventing this from working is the "deactivation" that kicks in, because your objects are stationary for so long. Go to the dynamics tag on the Voronoi Fracture : Dynamics > Deactivation > Linear/Angular Velocity Threshold. Set both to 0 to deactivate the deactivation :D.

 

Regards

Fritz

Share this post


Link to post

The dynamics visualization can be very helpful for debugging. The collision shapes switch color when they are below the threshold and also show when they are deactivated. Other than that: What Fritz said! 

Share this post


Link to post
Author of the topic Posted

Hi Fritz, hi Havealot,

 

thank you so much, that indeed did the trick! 

 

And as usual, two clicks away.. Thanks guys! 

 

Regards

 

Share this post


Link to post
Author of the topic Posted

Follow up question: why does the simulation not work set at "on collision"?  

Share this post


Link to post
Author of the topic Posted (edited)

So: I didn't include this object in the first project file as I thought the problems are the same, turns out they are not.

I also have a pedestal in the middle of rock field (modelled cube with Voroni Fracture). Two problems seem to randomly appear (Im sure they are not random though...)

1. : If the pedestal is set to "on collision", with the rock dynamics enabled they sphere hits the pedestal but most of the times leaves the top bit untouched.

2.: If I delete the floating rocks from the project and don't change anything, the sphere doesn't touch the rock at all.

3.: If is set the pedestal to immediately if slowly drifts appart (I assume because there are no connectors and the gravity is 0?)

 

I followed your advice and it looks like the cube I used to generate the rocks, originating in the middle of the pedestal has a bounding box (not sure if that interferes with the pedestal dynamics) 

 

I would also like to adda floor to the scene so the pieces (after being hit by the sphere) bounce of the floor but that caused my pedestal to break apart immediately. 

Yesterday sometimes the pedestal would just explode, regardless on what setting it is on.

 

Thanks for your time and I appreciate all your help!

 

Attached the project file with the pedestal. 

ExplosionStonesAndPedestel.c4d

 

 

EDIT:

It seems to have something to do with the animation of the sphere (only the radius is animated) -> Having the pedestal set to on collision implies that something has to be moving, does c4d see the animation of the radius not as movement as the object itself stands still? It works if I animate the sphere*s Ya-Axes coordinates.

Edited by Flonoel
New information

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...