Jump to content

Menu bar items not clickable + UI Scaling Issues on 4K laptop


Recommended Posts

I'm tearing my hair out over issues regarding some UI scaling issues on Cinema 4D R21. I recently upgraded my laptop to a top of the range Dell XPS with UHD 4K screen, thinking it would be a great piece of kit for using Cinema and other graphics programs in.

However when I open Cinema, by default the UI icons / text / elements are miniscule - understandable, due to the 4K screen being such high resolution. However the mouse clicks on the menu bar don't even seem to register at all, I can click on the icons just below the menu bar, but when I do they open up as a full screen rather than drop down. Clicking anywhere in the viewport seems to snap my cursor right to the very top left of the window:

 

Hard to know exactly what the issue is here, at some point I managed to get the UI to be scaled okay and reactive to mouse clicks, on a secondary monitor (1900x1200 resolution), but couldn't ever get it to be properly functional on my laptop's main screen. After restarting the app at some point it now seemingly doens't want to play nicely on either screen again.

As i've seen mentioned elsewhere i've tried to play around with the various settings available under the "Compatibility" tab in the application's settings, trying to use various scaling overrides / toggles but these settings are confusing at best and nothing seems to work any more.

 

Any ideas, am I just destined to find it a buggy unusable mess on a 4K setup? Even dropping my laptop's res down to 1920x1080 doesn't seem to do the trick - the UI is a bit more reasonable scaled to a good size but the menu bar items still aren't clickable.

EDIT: Attaching my full specs in case that helps. All my drivers and software updates are up to date etc.

 

OS Name    Microsoft Windows 10 Home
Version    10.0.18363 Build 18363
Other OS Description     Not Available
OS Manufacturer    Microsoft Corporation
System Name    DESKTOP-9QC48JP
System Manufacturer    Dell Inc.
System Model    XPS 15 7590
System Type    x64-based PC
System SKU    0905
Processor    Intel(R) Core(TM) i9-9980HK CPU @ 2.40GHz, 2400 Mhz, 8 Core(s), 16 Logical Processor(s)
BIOS Version/Date    Dell Inc. 1.6.0, 06/02/2020

The screen has a touch interface too, wondering if that could somehow be a factor? 

 

Annotation 2020-05-12 174423.png

screenshot2.png

Link to post
  • 1 month later...
  • 3 weeks later...

It's interesting what you wrote. I have a 4K 27 "monitor and I have not observed any problems in R21 or S22. I additionally use Windows 150% scaling. Screenshot below.

 

This problem must be related to your configuration. I recommend that you report the problem on the MAXON website:
https://support.MAXON.net/index.php

 

 

4K-menu.jpg

Link to post
  • 1 month later...

I am having this exact same problem. It occurs only on R21 and S22 (I reinstalled R20 and R19 and confirmed the issue is not present). I tried the same scaling / compatibility / DPI tricks and nothing has fixed the problem. I'm essentially stuck using R20 at the moment until I find a solution.

Link to post
One of the reasons could be having fiddled with the Win10 resolution settings (there are several options that overwrite the HiDPI behaviour and trick the app into thinking it's running into a low res screen), or having dialed the window scaling to 100% instead of 200 (or higher) which would be natural for 4k
There could also be a problem between the intel gfx driver and the NVIDIA driver. The NVIDIA driver can be disabled in its settings (assuming this is a reasonable up to date driver). That would at least reduce the number of variables (of what could go wrong).

U Render Quality Assurance Specialist

Link to post
  • 2 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...