Jump to content
Sign in to follow this  
Heguemo

Why does Cel Shader cause Shadow Maps to be rendered ?

Recommended Posts

Posted (edited)

Hello,

 

First post here and obviously looking for help... 🙃

So this is the situation, I've got this scene whit mostly luminance materials with cel shader, no sketch and toon lines, 3 lights, one of the with raytraced shadows. There is a big cloner and a bunch of sweeps, symmetries and hypernurbs. Got a bunch of cameras and a Stage object, I deaactivate the large cloner for sanity when it gets out of view.

 

Even with al this render on the viewport is around 3 seconds (I have put the same number of subdivisions on the hypernurbs for viewport to check if that makes any difference, my screen res is 1440p so the window would just be a little smaller than the 1080p output) but when I render to the picture viewer it just sits on "Rendering Shadow maps" for 10 minutes. What shadow maps?

 

Not sure if the animation would be a problem, but in any case activating "cache shadow maps" doesn't seem to improve render times. I've tried to copy the objects into a new scene with no improvement. Deactivting the Sketch and Toon option on the render settings leaves me with a virtually identical image as I have no lines and materials depend on the Cel shader, but this does not help with render times either. There's also a cloth simulation but it's cached, it just plays nicely on the viewport and can render any frame without trouble.

 

I have been searching but did not found anyone with a similar problem so I'm a bit stuck. I'm not sure I would be able to upload the scene as it not only dependes on me. Thanks in advaance for all your awnsers, ask anything you consider could be helpful.

Edited by Cerbera
Re-titled for future search use

Share this post


Link to post

Which renderer are you using, and what settings have you dialled in for it ?

 

CBR

Share this post


Link to post
  • Topic Author
  • Author of the topic Posted

    Hi,

     

    Standard render, 1080p, 30fps,  had not changed much from the standard settings, I only have tried "cache shadow maps" and reducing the Shadow Depth to 1 as it makes no difference on my Raytraced shadows.

    AA Best, 1x1, 4x4, Cubic.

    I've got some multipass: Object buffers and depth.

    Object Glow

    Sketch and toon, with no lines and quantize 6 steps, but I ended up getting rid of S&T as the shading really depends on my CEL shaders.

     

    Thanks!

    Share this post


    Link to post

    Ok, and what are the shadows set to for the other 2 lights in the scene ?

     

    There are other questions as well, but we can really save time here if you can upload a stripped down scene file. Just take out the stuff you don't want to share and put a test object in using the same material. Then we can see all the settings we need at once which is most helpful...

     

    CBR

    Share this post


    Link to post
  • Topic Author
  • Author of the topic Posted (edited)

    None, all three lights are point lights, no falloff.

     

    Just gave it a try with Physical as I'm not using S&T any more but same result, fast viewport render, stuck on Rendering Shadow Maps on Picture viewerr

    Edited by Heguemo

    Share this post


    Link to post

    No Physical is not the answer if you are using cel shading. 

     

    Do a quick test for me, will you ? Delete the cloner from the scene and then do a PV standard render, and tell us how long it takes now to render shadow maps...

     

    CBR

    Share this post


    Link to post
  • Topic Author
  • Author of the topic Posted (edited)

    That's it, back to three seconds per frame.

     

    Cloner is multi instance, has a model with animation, no joints, just rotations. Model has subdivison surface.

    Edited by Heguemo
    grammar

    Share this post


    Link to post

    Ok, that's progress then. So, do we absolutely need that cloner to have the shadows ? If we can get away without them, then we can exclude that object from receiving shadows with a compositing tag. If we do need shadows on that, then you need to do a further test to see if the shadow cache option makes a viable difference AFTER the first frame. So put up with the 10 minutes, and see if it's the same on the next frame. In theory it shouldn't recalculate them.

     

    CBR

    Share this post


    Link to post
  • Topic Author
  • Author of the topic Posted

    Cache shadow maps doesn't change anything after the first frame, camera and the clones have animation so maybe there's the culprit. Will try to not allow the clones to recceive shadows and see if that is ok for the scene.

     

    Just for my sanity, does it make any sense that it still has to calculate shadow maps when I only have raytraced shadows?

     

    Thanks!

    Share this post


    Link to post
    1 hour ago, Heguemo said:

    Just for my sanity, does it make any sense that it still has to calculate shadow maps when I only have raytraced shadows?

     

    Thanks!

     

    No. In theory you should be getting no shadow maps rendering at all, so that dialogue shouldn't even appear ! But we have very little chance of knowing why that might be until you upload the scene file...

     

    CBR

    Share this post


    Link to post

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    Sign in to follow this  

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×
    ×
    • Create New...

    FORUMS INFO:

    Dear members, we are aware of few more bugs that are still present withing the theme.We just wanted to let you know that we are working to fix them as soon as possible.
     

    NEW MEMBERS:

    Please be aware that we are manually approving all new registrations, due to spam prevention. Please be patient in case you cannot login right away, we will approve you within 12h or less if we decide you are not potential spammer. 

     

    Thanks for understanding! :cowboypistol: