Jump to content

Sign in to follow this  
M G

flag on a moving flagpole

Recommended Posts

Hi All,

As the title says, I'm trying to animate a flag on a moving flagpole and having a problem. Even moving the flagpole (repositioning it in a scene) and having the flag move is not working that great.

I have a flag, and a flagpole. The flag has a cloth modifier on it and is attached to the pole with the cloth belt. I run the animation and all is good. I've set it up so the flag and the pole are both within a null. when I move the null, the flagpole moves but the flag does not move with it in real time. If I disable the cloth modifier, move the null, then re-enable the tag, the flag catches up but not from frame 0. It snaps to position, which is not what I'm going for.

I'm finding that I have to reset the cache, remove the tag, deselect points, move the null, then reapply cloth modifier and cloth belt. 

Have I set this up wrong? My short term goal is to have a flag and flagpole that can be repositioned in my scene without resetting things. I thought the cloth belt would link it to an object and take care of that. Even better for longer term would be to animate the pole moving and the flag with it. 

I know this might not be totally clear, so I've attached a demo file. The flag is attached to a sleeve on the pole.

Thanks in advance to any suggestions!

Flag_demo.c4d

Share this post


Link to post

In R21, the flag does move with the pole, and apart from some intersection issues caused because the pole itself has no cloth collider tag on it, that is actually working in my viewport with your current setup !

 

flag_move.thumb.gif.dddb69f83e67b26e042e82a47d455a78.gif

 

However, if you cache the flag with the pole stationary, then obviously it can no longer respond to any movement you subsequently make with the pole. But you can cache the cloth AFTER you have recorded any pole movement animation and then it should cache the flag movement including that caused by the animated pole.

 

Not sure if that answers your question as to why that may or may not work in R19, but I don't have the version installed any more to test in...

 

CBR

Share this post


Link to post
  • Topic Author
  • Hi Cerbera,

    Thanks so much for the reply! I forgot about the pole collider, will have to update.

    After reviewing I think have stated my question wrong, my apologies. Where I'm struggling is if I have the flag null on frame 0 with all the cloth/belt properties set correctly, and then realize I want to move the starting position of the flag null. If I move that null (still at frame 0) everything moves but the flag. My workaround has been to remove the tags, move the flag null, and then reapply the tags. Is this the only option? Can it be repositioned (at frame 0) somehow without removing the tags? 

    Thanks!

    Share this post


    Link to post

    Yes, you can just turn off cloth tag (basic or options tab I think) while you get the initial position right. That is key-frameable as well.

     

    CBR

    Share this post


    Link to post
  • Topic Author
  • Thanks again for staying with this.

    Maybe I'm doing something wrong, but when I uncheck enable, and move, everything is ok. Then when I re-enable the cloth modifier, the flag goes back to it's original position. Might be something to do with R19.

    Thanks for the help. 

    Share this post


    Link to post
    Just now, M G said:

    Then when I re-enable the cloth modifier, the flag goes back to it's original position.

    Oh yeah, you would have to set the cloth belt again at the new position to fix that...

     

    CBR

    Share this post


    Link to post
  • Topic Author
  • Thank you Cerbera!

    I thought I was doing something wrong, the clarification is much appreciated!

     
     

    Share this post


    Link to post

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    Sign in to follow this  

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×
    ×
    • Create New...