Jump to content
Sign in to follow this  
HippoDasTamus

Mixamo Control Rig over Motion Clips - Is it possible?

Recommended Posts

Hi!

 

Using the Mixamo control rig to control over keyframed Mixamo animation (as is the standard when importing Mixamo mocap data) works fine, as can be seen in numerous tutorials. 

But what if I made motion clips from the Mixamo data? It seems I am not able to override the motion clip expression with my control rig. Is there any priority setting somewhere or any way to achieve this? I find handling animations with motion clips so much easier than with a bunch of keyframes ...

Grateful for any input / experience on this 🙂

Share this post


Link to post
  • Topic Author
  • Author of the topic Posted

    And to specify, I add the motionclips to the joint hierarchy only, not the whole character, so there should actually be no conflict there

    Share this post


    Link to post

    I haven't looked but while the Mixamo Character rig controls the Mixamo bare rig Motion clips are not cross compatible as there will be controlers within the Mixamo character rig and the Motion system will include them in the hireachi. Until I have a check I would think that your best to put your motion clips together, then  put the whole animation backed back into keys.  Add Mixamo control rig to adjust areas of the animation.  Another thing I haven't looked at is of you can use Animation layers for the mixamo character control rig as this would make sense to keep the keys separate from the target mixamo keys.

     

    If its the case that you just cant use the Mixamo character rig while the mixamo keys are baked into motion clips you may need to add a layer within the motion clips an place it at the top, above the mixamo target.  So to be clear the bare mixamo motion clips below and the mixamo character rig keys above.

     

    Dan

    Share this post


    Link to post
  • Topic Author
  • Author of the topic Posted

    Hi Dan, thanks for your answer! Ok, I almost guessed it wouldn't be easily possible, but I don't really understand how the motion clip that is only on the joints itself could wield power over the controllers from another hierarchy - very strange. I will try to use a relative animation layer on top, and see if that works. Otherwise the baking solution doesn't seem too bad either, I guess if i put markers around the former motion clips I can still tell them apart.

    Share this post


    Link to post
  • Topic Author
  • Author of the topic Posted

    This is very strange - after trying around a bit I am now unable to move any controls on my rig, even without motion clips and strangely enough even in files that I haven't touched and which worked perfectly fine before it is now suddenly no longer possible. I have tried to restart Cinema, but the problem persists. I cannot think of anything that might have caused this ... all other objects I can move normally and I can move the controllers ny constraining them to another object, but the controllers themselves seem to be locked off completely

    Share this post


    Link to post
  • Topic Author
  • Author of the topic Posted

    So -

    It seems the problem with the motion clips wasn't actually a problem. Using the Mixamo rig over motion clips works perfectly fine. The thing was that my morph tag priorities were interfering with the motion clip keyframe / rig relationship and that was causing the controllers to not move at all due to being constrained by the morph expression. I have now worked with the priorities a bit and figured out a setting that allows me to first have the keyframes come over to the joints, then have the rig contorl corrections on a second relative layer (it also works without layer) and then having the pose morph come in last. Puh

    Share this post


    Link to post

    Do you have the morphs set to post deformers?

     

    Dan

    Share this post


    Link to post
  • Topic Author
  • Author of the topic Posted

    I thought so, but actually no, they were not set to post deformers. I should probably do that right?

    Share this post


    Link to post

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    Sign in to follow this  

    ×
    ×
    • Create New...

    IMPORTANT INFO:

    We are in the progress of finalising upgrade to Cafe 3.0. If you are experiencing issues, please change the default theme to Cafe 2.5 and thing’s should work again. We will notify everyone when we resolve all the issues.
     

    It would be also great if you could report any issue you might have on your side so we can fix them. :cowboypistol: