Jump to content

Sign in to follow this  
Eliel Souza

Particle moves along the surface RESPECTING the NORMAL DIRECTION

Recommended Posts

Hey guys.

 

Im trying to do that a xpgenetor (with cilynder) moves around the surface object (a sphere, using the xpFollowSurface) keeping the normal direction from the sphere.

I tried some steps:

1 - Enable Extended data Rotaion as Tangential, and set the Up Vector to Y axis.  Here the born particles got the inicial normal direction - Done!

2 - I animated the particle using a simple xpTurbulence. Here the particles starts movinig around the sphere - Done!

3 - But, as long the particles moves around, each particle get stuck in the only one direction from the normal, from the first frame. How to solve that? To to de particles changes the orientation along the surface when they moves?

 

 

 

Attached some prints and de c4d file.

 

Thank you very much!

 

previz.gif

3.JPG

1.JPG

2.JPG

xparticles_surface_orientation.c4d

Share this post


Link to post

Got it!

It works with these settings:

Cinema_4D_EAaBqc6wTe.png.1d149062afbe8b5f9f1189e85d559f55.png

Up Vector does exactly what you want, as described in the documentation:

"This mode deals with the problem of axis flipping (especially on bank) when particles are moving over a surface using the Follow Surface modifier. Often, you will want the particle to maintain the same orientation with respect to the surface despite changes in direction. To enable this, select this mode, which will make the Y-axis of the particle perpendicular to the surface.

Note that this mode only works with the Follow Surface modifier at present. With all other modifiers it has no effect."

 

Then to arrange the Cylinders correctly you have to change the axis on the object

Cinema_4D_LO1Ll9swNy.png.d6e596dfbeb390db00a2f163061ff7c8.png

 

After that it worked for me 🙂

 

 

xparticles_surface_orientation_fixed.c4d

Share this post


Link to post
17 minutes ago, DasFrodo said:

Got it!

It works with these settings:

Cinema_4D_EAaBqc6wTe.png.1d149062afbe8b5f9f1189e85d559f55.png

Up Vector does exactly what you want, as described in the documentation:

"This mode deals with the problem of axis flipping (especially on bank) when particles are moving over a surface using the Follow Surface modifier. Often, you will want the particle to maintain the same orientation with respect to the surface despite changes in direction. To enable this, select this mode, which will make the Y-axis of the particle perpendicular to the surface.

Note that this mode only works with the Follow Surface modifier at present. With all other modifiers it has no effect."

 

Then to arrange the Cylinders correctly you have to change the axis on the object

Cinema_4D_LO1Ll9swNy.png.d6e596dfbeb390db00a2f163061ff7c8.png

 

After that it worked for me 🙂

 

 

xparticles_surface_orientation_fixed.c4d 281.71 kB · 1 download

 

.

.

.... DasFrodo, You are just amazing! Saved my work! It works perfectly! 🙂

 

Thanks a lot!

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...