Jump to content
Sign in to follow this  

C4D R21 OpenGL Animation Preview

Recommended Posts

This is probably not Redshift specific, but I stumbled upon this problem when using Redshift. Sorry if it's in the wrong place.


So, If I render an OpenGL animation preview using the new Redshift node materials in R21 all show up black.

In the viewport they’re fine. Old Xpresso based materials are also fine in the OpenGL animation preview.


Is there any way to make the node materials work too in the animation preview?


Basically it looks like the animation preview is using the standard/physical node space because when I switch to that all materials are black in the viewport as well. So, can I force the animation preview to use the Redshift node space?

Thank you.

Share this post

Link to post
  • Topic Author
  • Author of the topic Posted

    Nobody has any idea?


    As I understand it's the same with S22. In fact, that one might be worse since it seems that the viewport quality setting for Xpresso-based Redshift materials doesn't work anymore (changing the viewport texture resolution) and it seems they have issues updating in the viewport. So in S22 I'd be essentially stuck with node-based materials which I can't make show up in the animation preview.


    I would have thought that since they bought Redshift the integration will be better, but so far I see it's getting worse.

    Share this post

    Link to post

    Question - Are you making this preview by going to [Render -> Make Preview] or do you have a dedicated render setting for Hardware OpenGL?

    You might have more luck or control in the latter possibly and rendering it out to picture viewer

    Share this post

    Link to post

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    Sign in to follow this  

    • Recently Browsing   0 members

      No registered users viewing this page.

    • Create New...


    Dear members, we are aware of few more bugs that are still present withing the theme.We just wanted to let you know that we are working to fix them as soon as possible.


    Please be aware that we are manually approving all new registrations, due to spam prevention. Please be patient in case you cannot login right away, we will approve you within 12h or less if we decide you are not potential spammer. 


    Thanks for understanding! :cowboypistol: