Jump to content
Sign in to follow this  
benek

Xpresso AFTER deformers

Recommended Posts

Just got a scene where I'm trying to calculate the length of a spline after deformation, but I can't seem to get the Xpresso to work after the deformer. I've tried changing the priority order but it doesn't seem to change anything. My spline is attached to some geometry using a surface deformer. I've attached a simple scene, would be grateful if anyone knows the answer. I can create a workaround using a mospline but it's not the most elegant solution.

Untitled 6.c4d

Share this post


Link to post

Use xpresso calculating distance between first and last point of spline and for point nodes enable option "Use Deformed Points"

UDP.thumb.png.339de9b45f73327581c1fc7d10ab2dae.png 

Share this post


Link to post
  • Topic Author
  • Author of the topic Posted

    @bezoI can see that your example would work … maybe I didn't provide the best example file… Although in my attached C4D I used a straight spline, I'm looking to get this working on curved splines…

     

    My workaround was to create a Mospline set to spline mode and insert my deformed spline into that, and then read the length of the Mospline instead, but it would save that extra step if I could just read the length of the first spline.

    Share this post


    Link to post

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    Sign in to follow this  

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×
    ×
    • Create New...

    FORUMS INFO:

    Dear members, we are aware of few more bugs that are still present withing the theme.We just wanted to let you know that we are working to fix them as soon as possible.
     

    NEW MEMBERS:

    Please be aware that we are manually approving all new registrations, due to spam prevention. Please be patient in case you cannot login right away, we will approve you within 12h or less if we decide you are not potential spammer. 

     

    Thanks for understanding! :cowboypistol: