Jump to content

Vertex Map not working after binding character.


JBBC
Go to solution Solved by bezo,

Recommended Posts

Hello! 

I have an issue with the hair of my character. 
After binding, the vertex map is not recognized anymore and it's impossible to relink it. The hair cover my character fully. 

How can I relink my hair to the vertex map after binding? 

Thanks!  

Project file with example before and after biding: 


https://www.dropbox.com/s/fmpr46dor7j1zvs/Flamingo_V2.c4d?dl=0

Capture d’écran 2020-10-16 à 16.01.38.png

Capture d’écran 2020-10-16 à 16.01.25.png

Link to post
  • Solution

When you grow hair (set guides) from vertex map, you need also to tell hair object to generate hair from this guides. If you leave option Auto in Hair tab, hair will cover whole object.

If needed more dense hair, you could use cloning option or adding guides...

 

hair.thumb.png.d220b93dfd19fdb7d5fd903a39c9f574.png

 

Roots set "As Guides" in both hair objects.

 

hair_1.thumb.png.12bb25af8c790826d824f9fc03a9200a.png

Link to post

Looks like skin deformer collide some way with vertex maps when active. So, solution was disable skin deformer, creating new vertex maps, adding new hair restricted to those maps and then again enabled skin deformer. If while applying /adjusting vertex maps hair not update immediately, click "Update Guides" on the bottom of Guide tab...

Link to post

When last time I look into the scene, found a problem...

Always when look on hair object, I see green circles aroun the roots. And it means "un-rooted" hairs, which in result behave like applied on static object ...

 

So, when you don´t create new hair as I recommend in previous post (repetition means learning 🙂 )

 

1, select hair object

2, select all

3,set roots

4, apply

 

(must use hair selection/edit tools)

 

1.thumb.png.dea55f1d0504cb8b799401c87e0ce15f.png

 

result

2.png.55943649d06af1abd82c97f11ee21168.png

 

and neck

3.thumb.png.9b976d259d14b56331e80d1e7c3b0e33.png

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...