Jump to content

Redshift Volume Alpha


Recommended Posts

I asked this question before at Redshift, and was still unable to get this to work so I'll re-ask it here.

 

When rendering a volume (created with X-Particles), the heat channel is not shown over an alpha background (see attached files). I tried different render file formats and every program I use to load the files (After Effects, HitFilm, Fusion,  Photoshop..) all don't show it.  I tried using separate alpha channel mode, and different alpha modes in the image editing software.

Volume_Alpha_Example_Alpha-Off.png

Volume_Alpha_Example_Alpha-On.png

Link to post
  • Silver Contributor

Is your volume actually generating an alpha channel?  check using the RGB / A button in the render view when in bucket mode.

Link to post
  • Silver Contributor

I think I'm right in saying that the alpha is created from the absorbtion channel in the Rs volume settings - so if there is nothing in there, you won't get an alpha. Unfortunately i don't have any experience using the X-particles volume / heat channel, but that might be a starter for you. Could you feed the heat channel into absorption and see what happens?

Link to post

Thanks Mike. One has to wonder what RBGA channel Redshift is rendering to. Again, the problem is it’s simple not shown if alpha is behind it (see my attached picture) the jet thrust disappears once over the background. If there’s an object in the background, the thrust will only show where there’s ‘something’ behind it.

 

 As far as X-particles, I’m saving and rendering using VDB files.  

Link to post
  • Silver Contributor

Robert,

You can get an alpha by adding a vdb channel to the absorption parameter - like the attached image,  but...

 

I suspect this is not the best approach. Are you aiming to render out a full image directly from RS with a background - or are you aiming to rebuild everything in post as a multi-layered composite?

 

If it's the latter I would not be using an alpha for your thruster emission. I would simply render it out as an AOV - the emission should appear in the 'VolumeFogEmmission' AOV - and composite that over your other elements in Add mode. That would mean you'd need to render out all the constituent layers individually as well; or you could do two render runs: one full image minus the emission element, one run with the emission element only.

 

Screenshot 2021-01-13 214150.jpg

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

ABOUT US

We are dedicated Cinema 4D Community of friendly and passionate artists, hobbyists and developers. Feel free to join us to share your knowledge, your art and anything that might help Community to grow. We are providing guidance, free plugins and files, feedback, sponsorships and various discounts for our Contributors and much more. :cowboypistol:

×
×
  • Create New...

Copyright C4D Cafe © 2021 Powered by Invision Community