Jump to content

Archived

This topic is now archived and is closed to further replies.

Guest john_trueblue

Light Bleeding Along Edges

Recommended Posts

Guest john_trueblue
  • Topic Author
  • i have a cube as a room with 2 lights, one out side and one inside.

    seems the light out side is bleeding inside along the corner and edges along the wall.

    how would one stop this.

    i remember some where along this topic that it had to do with the shadow settings but for the life of me i cannt remember how.

    JTB

    Share this post


    Link to post

    You can give the wall some thickness , extrude with the caps option on.

    Peace,

    Rich_Art. ;)

    Share this post


    Link to post
    Guest dataflow
  • Topic Author
  • Author of the topic Posted

    disable "absolute bias" in shadow tab

    then turn up "bias (rel)"

    Share this post


    Link to post
    Guest john_trueblue
  • Topic Author
  • Author of the topic Posted

    disable "absolute bias" in shadow tab

    then turn up "bias (rel)"

    thats not working!

    i then switched the shadow map to 2000x2000 and that minimized this bleeding down to about 1%

    but the corners still show a little bit of the light from out side.

    here is the scene file.

    JTB

    oops didnt see richard post, will try that.

    Share this post


    Link to post
    Guest dataflow
  • Topic Author
  • Author of the topic Posted

    dont know y but v10 does the opposite of v9

    in v9 my advice works in v10 it makes it worse :unsure:

    Share this post


    Link to post
    Guest dataflow
  • Topic Author
  • Author of the topic Posted

    you could just change your shadow to area shadow

    Share this post


    Link to post
    Guest john_trueblue
  • Topic Author
  • Author of the topic Posted

    you could just change your shadow to area shadow

    could this be a bug in V10-10.1?

    cause now i do remember this was the way to go in the demo of v9.1 and i believe in v10 too.

    need more feed back from people that havent updated to V10.1 yet.

    JTB

    Share this post


    Link to post

    Either....put a polygon outside of the corner to block light, lower the bias but don't turn it off, or bevel your corners slightly so they are not complete 90 degree angles. (they wouldn't be in real life anyways)

    Or another option would be to make all the walls into one object and weld their edges together. That would prob sort it too...

    Morph

    Share this post


    Link to post
    Guest Damsel
  • Topic Author
  • Author of the topic Posted

    Another option.. use a cube for the outside walls of your room and zoom inside. Use booleans for the windows and doors. Light shouldn't leak in then since there would be a solid framework for the outside walls. Just a thought. ;-)

    Share this post


    Link to post
    Guest john_trueblue
  • Topic Author
  • Author of the topic Posted

    guys/gals

    im using a cube (primitive) that has cuts for the window and the safe recess.

    might just have to remodel the whole room (cube).

    JTB

    Share this post


    Link to post
    Guest
    This topic is now closed to further replies.

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×
    ×
    • Create New...

    FORUMS INFO:

    Dear members, we are aware of few more bugs that are still present withing the theme.We just wanted to let you know that we are working to fix them as soon as possible.
     

    NEW MEMBERS:

    Please be aware that we are manually approving all new registrations, due to spam prevention. Please be patient in case you cannot login right away, we will approve you within 12h or less if we decide you are not potential spammer. 

     

    Thanks for understanding! :cowboypistol: