Jump to content

Archived

This topic is now archived and is closed to further replies.

Orien

Animating Transparency

Recommended Posts

  • Topic Author
  • I have a layer of text superimposed over another texture on an object. Works fine, but i need to fade it out.... making the text invisible. What value would I keyframe in order to do this?

    Share this post


    Link to post
    Share on other sites

    The visibility of an object can be keyframed. To the left of "Visible in Renderer" is a little circle. Cntl-click it and it turns red which means you have created an animation track and set a keyframe. Go to the point in the timeline where you want the text to start fading and Cntl-click it again. Proceed to where it must be invisible and set "Visible..." to Off (the default is on).

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • Awesome! Thanks so much smile.gif

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • Actually, after trying it, i can't do it... it's not an object but a material. How do i key out visibility of a material?

    Share this post


    Link to post
    Share on other sites
    Guest StructAural

    You should be able to keyframe values in the texture dialog box. For instance with Colour you can bring the Brightness down over time (alt click the little circle next to Brightness - change frame, change brightness and alt click again the circle). You can do the same with most other things.

    Hope this helps.

    Share this post


    Link to post
    Share on other sites

    Yups that is the way.

    Here is a quick example anim and the file.

    Take a look at the blue material and then in the transparency channel.

    Peace,

    Rich_Art. wink.gif

    Share this post


    Link to post
    Share on other sites
    Guest mAssimo

    I animate the material's visibility with the Alpha property, using Colour under Texture and setting keyframes i.e. from White (visible) to Black (invisible). Hope it helps...

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • Thanks guys.... unfortunately, that's not working either.... Let me give you the set up.

    I have a floor object, on the bottom most layer, plain white material. On the layer above that, a material with jpegs for color and alpha. The effect is a decal of text. When I put a transparency channel on it, and make it so that it becomes invisible in the viewport and in the material editor, all it does in the image is turn black, basically making a hole in the other material.

    Any suggestions?

    Share this post


    Link to post
    Share on other sites

    Upload your file and I have a look at it.

    Peace,

    Rich_Art. wink.gif

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • Here ya go... I set it up so that it makes a bit more sense...

    The words should just fade off of the green instead of cutting a hole through the object.

    Share this post


    Link to post
    Share on other sites
    Guest StructAural

    You need to include your textures - go to file - Save Project and then zip that folder and attach again.

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • Ugh, stupid mistake on my part. Thank you for your help. :)

    Share this post


    Link to post
    Share on other sites
    Guest
    This topic is now closed to further replies.

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×
    ×
    • Create New...