Jump to content

Archived

This topic is now archived and is closed to further replies.

Guest tennet

Alpha Channel Problem..

Recommended Posts

Guest tennet
  • Topic Author
  • Hi everyone!

    I'm having some trouble to get the alpha channel working when adding an backimage. As in this example I can't get the white background to disappear?!

    I made a selection surrounding the object in PS, then added a new alpha channel and saved it as a PSD with the alpha channels included.. Can someone please check the attached PSD-file and see what I have done wrong?

    Thanks!

    Share this post


    Link to post
    Share on other sites

    Guest dataflow
  • Topic Author
  • i havent checked the file but it could be because the black makes the image background disappear not the white

    Share this post


    Link to post
    Share on other sites
    Guest tennet
  • Topic Author
  • Thanks for your reply. I went back to PS and inverted the alpha, but it's still the same. Nothing really happens when I switch between "None", "Normal" and "Inverted". In Normal mode I can reduce the opacity using transparency (see attached), but that still applies to the whole backimage and not just the background.

    I've checked the tutorial about this, but I couldn't follow because of the same problems. Any other tips?!

    Share this post


    Link to post
    Share on other sites
    Guest

    I have checked your psd file for you. What you need to do is load the alpha selection and inverse to delete it. You need to end up with the transparent checkerboard in photoshop. That way your alpha will work in cinema.

    Here is your fixed file.

    Hope it helps

    Steve

    Share this post


    Link to post
    Share on other sites
    Guest tennet
  • Topic Author
  • Thanks Steve, your alpha channel works if I for example load it into a material, but I still can't get the same alpha channel to work with the backimage (I loaded your fixed file). I followed one tutorial where they explained how to do it, but since it didn't work I wanted to know what I did wrong.. any ideas?

    The work around by changing background colors works fine though, thanks for that tip!

    Share this post


    Link to post
    Share on other sites
    Guest

    Go to your front view and hit shift and V

    Now in the background put the fixed file.

    Change the alpha to normal.

    Here is a screencap with what happens on mine. If you are still having probs delete your prefs folder and reboot.

    Hope you get this sorted.

    Cheers

    Steve

    Share this post


    Link to post
    Share on other sites
    Guest tennet
  • Topic Author
  • Hi! That's exactly the effect I'm looking for, but it doesn't work.. I deleted the prefs-folder, restarted the system and it's still the same. Then it must be some other stupid setting somewhere. I'm running on MacOSX - does that mather?? Anyways, thanks for your help!

    Share this post


    Link to post
    Share on other sites
    Guest

    In theory mac or pc it should not matter.

    I have no idea what could be the matter. :nonono:

    I hope you manage to get it sorted out whatever it is.

    Let me know what the problem was when you get to the bottom of it. spoton.gif

    Steve

    Share this post


    Link to post
    Share on other sites
    Guest

    The only other thing I can suggest is that you try it in a brand new scene and see how you get on. Sometimes the file itself can get a bit screwy.

    Good luck :thumbsup:

    Steve

    Share this post


    Link to post
    Share on other sites

    An easy way is to set you reference image up in Photoshop or whatever. Just so long as you have the checkerboard texture visible on the same layer or the background layer then save as a tif file. You then load as a background in C4D and enable "Normal" mode for the alpha mode in the background image settings. Saving as a tif flattens the image down to one layer and has the alpha channel built in.

    Here's a tif to try it on.

    3DKiwi

    Share this post


    Link to post
    Share on other sites
    Guest tennet
  • Topic Author
  • Hi 3DKiwi, same problem still.. I loaded your "bg.tif", but the black text is still on a white background when alpha "Normal" is enabled... ? Could there be any display settings or any preferences in C4D that causes the problem?

    Share this post


    Link to post
    Share on other sites

    Sounds like you're running in software display mode. Go into the preferences and enable OpenGL mode.

    3DKiwi

    Share this post


    Link to post
    Share on other sites
    Guest
    This topic is now closed to further replies.

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×
    ×
    • Create New...