Jump to content

Archived

This topic is now archived and is closed to further replies.

Guest tennet

Unwanted Background Is Reflected

Recommended Posts

Guest tennet
  • Topic Author
  • Hi!

    How do I get rid of the dark reflections in the tiles? I want the tiles to be reflective, but I only want them to reflect what is in the room, not the empty space on the outside. There are no other objects in the scene that can cause the dark reflections (as I'm aware of..). Hope someone can help me. Thanks!

    Share this post


    Link to post

    Try increasing the reflection depth to say 10 in the render settings options page. What you're getting here is the kaleidoscope effect. You might also want to reduce the reflection amount. Looks far to high to me. Try about 5%.

    3DKiwi

    Share this post


    Link to post
    Guest tennet
  • Topic Author
  • Here are my new settings and the render result. Those dark reflections are still there? Is there any setting that just makes the render to ignore the surrounding black background (so it doesn't take it into account when using for example reflections)?

    Thanks for your help! smile.gif

    Share this post


    Link to post
    Guest dataflow
  • Topic Author
  • the thing is what is it meant to reflect back if it doesnt reflect the background.

    you need to add a sky or something.

    and if you dont want it seen(still want black background)

    just apply a "compositing" tag to the sky and disable "seen by camera"

    Share this post


    Link to post
    Guest tennet
  • Topic Author
  • Hi! I plan to add some furnishing and things on the walls and I want them to be reflected in the tiles, not really the background of the scene. Is it possible?

    Maybe there is a better way to put this kind of scenes together? I just started with a box and erased two sides.

    Share this post


    Link to post
    Guest dataflow
  • Topic Author
  • how is your scene setup?

    it looks to me like you have a room(cube) and some holes(windows) and thats what is reflecting in the tiles

    if that is correct then the only way to make those black part go away would be to cover the holes(windows)

    Share this post


    Link to post
    Guest tennet
  • Topic Author
  • Here's my scene. It's very simple, I started with a cube, as you said, and just deleted two of the side polygons. Is there a better way two create a really small room (like this one) with all walls available?

    But then I would need to put the camera inside the room (since the walls will be in the way) and because of the short distances the camera won't be able to see the whole room.. Maybe I should create all walls as separate objects in separate groups instead? Then I should be able to hide the walls that I'm not using when I render, but then I would get this reflection problem again, I guess.

    Share this post


    Link to post
    Guest tennet
  • Topic Author
  • Anyone who please could have a look at the scene and give me a little hand? I can't find out how to get rid of the dark reflections.. I've tried and changed the different settings 3DKiwi told me to, but I still can't get it to render without the dark reflections. What am I doing wrong?

    Share this post


    Link to post
    Guest

    Just do what dataflow suggested. Add a sky object and add a compositing tag to it and uncheck seen by camera and hey presto fixed. spoton.gif

    Steve

    Share this post


    Link to post
    Guest tennet
  • Topic Author
  • Sorry Dataflow, I totally missed that your first post had the perfect solution. I read your second post about the holes in the wall and thought that the problem still had to do with that.. The composting tag solved everything! :)

    THANKS!

    Share this post


    Link to post
    Guest
    This topic is now closed to further replies.

    • Recently Browsing   0 members

      No registered users viewing this page.

    Latest Topics

    Latest Comments

    ×
    ×
    • Create New...