Jump to content
  • “Great art picks up where nature ends.”  Marc Chagall 

Archived

This topic is now archived and is closed to further replies.

Josephus

Zoom/move Issues

Recommended Posts

  • Topic Author
  • This seems to happen more often with an imported model, but every once in a while the move/zoom tool will not allow me to get close enough...it just moves a mm at most. What's going on and how can I "reset" that so I can zoom in really close?

    Share this post


    Link to post
    Share on other sites

    The imported model most likely has a very small scale. Go into the coordinates manager and scale the object up a lot.

    3DKiwi

    Share this post


    Link to post
    Share on other sites

    A good way to check is to set the Viewport > Edit > Frame Default and see how the model fits the frame.

    This will give you an idea of the actual size of the model.

    Some imported models need to be scaled by a factor of as much as 10,000.

    Cheers, Alan.


    Repeat after me: Path spline in TOP, profile in FRONT.

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • That was it, thank you, it was way too small and also quite a distance from 0,0,0.

    This lack of ability to use scale is a real pain for me, and yes, I've made the suggestion to MAXON. Seems like such an easy thing to do, if someone selects "inches", then automatically scale everything up 10x (assuming 10 C4D unit equals one inch), for a foot 120x, without me mentally having to do that for EVERY measurement.

    Share this post


    Link to post
    Share on other sites

    Why not adjust the preferences so that imported objects get scaled up by whatever amount you want. I think most import filters have some options. obj for instance usually needs scaling up 1000x.

    'bout time you yanks started working in metric like the rest of us isn't it?

    3DKiwi

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • 3dKiwi...no problem scaling as needed, but let's say I'm looking at a wall 96" high that I'm exporting out of Archicad, during export I can scale it up so 10 C4D units equals one inch (or whatever), but then in C4D when I measure the height of that imported wall it will dutifully be 960 (96 x 10). It doesnt really matter whether we're using inches, mm, or whatever. So then from thereon, anything I add or modify always has to be multiplied by a factor of 10 (I was told early on here that I should use 10 C4D units to my 1 inch). Maybe I'm missing something here....is there a way to scale up the model whether 10x, 100x, or 1000x, and still have that 96 (inch, mm, units) high wall measure out at 96 (inches, mm, units)?

    Also, am I not correct in saying that the units (inches, mm, meters, etc, all are quite meaningless in that if I start with an object that is 96 inches high, and change the units to meters, it will show as 96 meters and C4D will NOT make the numerical scale/ratio change as I would expect?

    My issue with scale is that I've been thinking in terms of (architectural) units (in my case inches and feet) for many, many years, and can relate how high something is in real life by that measurement. So for instance if I'm doing a 96 inch high wall, I know what that feels like, but now I have to make it 960 (units), and I have to say to myself, ok, that is really 96 (inches) and I know what that feels like.

    As far as us "yanks"...it's kind of funny considering the paragraph below in that I also am a Dutchman (born in Haarlem, Netherlands)....

    The Oxford English Dictionary suggests the most plausible origin to be that it is derived from the Dutch first names "Jan" and "Kees". "Jan" and "Kees" were and still are common Dutch first names, and also common Dutch given names or nicknames. In many instances both names (Jan-Kees) are also used as a single first name in the Netherlands. "Jan" means "John" and may have been used as a reference to the settlers of New-York (New-Amsterdam at the time) who were Dutch.[citation needed] The word Yankee in this sense would be used as a form of contempt, applied derisively to Dutch or English settlers in the New England states.

    Josephus, the Dutch Yankee :)

    Share this post


    Link to post
    Share on other sites

    Cinema does not make any physical conversion between different units. 96 units can be whatever you want.

    1" will not be converted to 2.54cm when you switch the units in the prefs. The units are relative not absolute.

    A single cube could represent a matchbox on a table but the exact same cube could represent a city block in a large street scene.

    It depends on which context the cube is used in. (and the subsequent texturing)

    Personally I don't use any unit names. I've disabled them in the preferences. I just 'think' in the appropriate units.

    I do understand how hard it is trying to switch out of "CAD mode".

    You will need to experiment with pre-setting the import scale factor.

    Get a basic 50x100x200 cubic CAD model, import it and scale it manually to match a C4D cube with the same values.

    When it matches, note the scale factor you used and set that in the Import Prefs.

    HTH. Cheers, Alan.


    Repeat after me: Path spline in TOP, profile in FRONT.

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • Alan, a 50 in x 100 in x 200 in CAD cube comes in to C4D as 50 units x 100 units x 200 units.

    Someone on this forum told me early on when I was starting my first (architectural) model to use 10 C4D units per CAD inch (maybe this was suggested since C4D units were based on mm where 25.4 mm equals one inch?). Do you agree it is either necessary or highly advisable to multiply the CAD units (inches) by a factor of 10 for architectural modeling? It would be a LOT easier for me if 50 CAD inches can be 50 C4D units.

    At what part of a whole C4D unit does the program start to have problems?

    Share this post


    Link to post
    Share on other sites

    Enable the grid and zoom out a little to show the full grid. As long as your model can sit comfortably within the bounds of the grid, then C4D doesn't have a problem. Even if it extends beyond the grid, C4D doesn't have any problems with larger objects.

    However if a complete model only occupies one 50x50 (C4D unit) square and you end up having to zoom way in to see, say a doorframe, then it is too small.

    Large scale is ok but if you start working at fractional C4D units then the rounding calculations get messed up. I'm not sure of the fraction but I think it is something like 0.001.

    A quick test using 1":10 C4D units: 50'=600"=6000 units.

    Using that ratio I can create a 50' wall and a 1" cube side by side and be able to zoom in and out with one sweep of the mouse quite easily.

    Even a 100' wall just extends beyond the grid.

    If I do the same thing with a 1:1 ratio, zooming becomes more sensitive and a little awkward to navigate.

    If you can put up with mentally knocking the extra 0 from the display I would personally adapt to that method.

    You could try reducing the mouse tracking sensitivity and go for the 1":1C4D if this zoom rate is a problem and see how it goes.

    It all depends on which you find the easier but the 1:1 should work.

    HTH. Cheers, Alan.

    PS. I always get the 25.4 mm/1" the wrong way round with 24.5. Just as well I didn't take up a career in architecture. wink.gif


    Repeat after me: Path spline in TOP, profile in FRONT.

    Share this post


    Link to post
    Share on other sites

    Hopefully no one was too offended at my light hearted jab at yanks smile.gif

    So the way I read it you have to work in decimal inches.

    3DKiwi

    Share this post


    Link to post
    Share on other sites

    Interestingly, although the model units are meaningless and can be what you want, C4D does know a bit about units from a maths point of view. If you have your default units set to meters for instance, try this experiment. Create a cube - this will be a 200m cube. In the X size box, type 100 ft. When you press enter, C4D will immediately convert this to 30.48m. You can enter in inches as well (but not ft in - C4D is resolutely decimal). Saves a bit of mental arithmetic. C4D can also accept most maths as an input so you don't have to get out your calculator as often as you might think.


    Steve

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • Alan, for the time being I'll stick with the 10 C4D units equals one USA Inch :)

    Steve's comment/exercise was very interesting....the only drawback I see with that methodology would be that all my measurements in C4D would be in mm and I would have to multiply by 25.4 to get good "ole USA inches, so probably easier to stick with a factor of 10 until C4D automatically mulitplies by a factor of 25.4 when I set the units to inches and/or import a model in inches. On the other side, I can export the model in mm out of Archicad, then using Steve's method, but then I would have to get used to metric measurements, which can also be done. Seems easier for a lot of us yanks if the MAXON programmers would do this for us.

    3DKiwi...I enjoyed the light hearted jab at "yanks", being a true "Jan-Kees" a la yan-kee m'self, although I'm not sure if "yanks" should be capitalized or not :)

    Share this post


    Link to post
    Share on other sites
    Guest
    This topic is now closed to further replies.

    • BLOGS / NEWS & SPECIAL ANNOUNCEMENTS

    About Us

    C4D Cafe is the largest Cinema 4D community. We provide facilities for discussion, showcasing and learning our favourite software.
    Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, watch tutorials directly from our video gallery,  get your own private messenger, post and upload images, manage your profile and much more. If you need to find solution to your problem or otherwise ask for help, C4D Cafe is the right place to be for learning 3D.  :cowboypistol:

    ×
    ×
    • Create New...