Jump to content

Archived

This topic is now archived and is closed to further replies.

Guest staubstudio

Shortcut To Open C4d In 64bit Mode On Mac Os X

Recommended Posts

Guest staubstudio

@doubledope : Yeah... I did read your post, but that's not how it works on Mac. The only way to use the 64bit is to popup the getinfo dialog, and uncheck the "32 bit mode" checkbox. I can't do that with a simple shortcut...

Seriously, how squashed for time can you be? And how often do you switch (an why)? And do you reboot that often? Other than or software installation I can't remember the last time I did a reboot.

We can't work in 64bit mode because there's an issue between c4d an our SAN storage... So we work in 32 bit, and render in 64bit. And we tend to ask a lot (I mean.... A LOT) of our workstations... so we do need to reboot pretty often.

I totally understand switching to 64bit for renders, you need the extra ram for renders, but why can't you use 64bit for the rest of the time?

Like I said above, there's an issue with our SAN storage in c4d, which makes it unusable in 64bit mode. So we work in 32bit, set everything up (render stettings, etc.), save, quit, launch c4d in 64bit, open the scene and hit render.

That answered... I think I've found a way. I duped my Cinema 4D.app file in the same folder and renamed in Cinema 4D 64.app. The 64 one has the "Run in 32bit mode" uncheck... Looks like it work... but I'm thinking tis might lead to problems some day... (I'm not sure how macos will deal with this... I guess everything should be ok...)

Anyway...thanks everyone for your ideas... Hope this will work, and that someone else might find this useful.

Have a nice day

J.

Share this post


Link to post

... we tend to ask a lot (I mean.... A LOT) of our workstations... so we do need to reboot pretty often.

I ask a lot of my workstations too. Most of them run 24 hours a day, 7 days a week at full tilt, many of them performing multiple tasks concurrently. Also, a lot of the jobs I do are just too big to work them in 32bit. I find OS X completely bullet proof, I never have to restart.

The SAN/C4D thing must be a real pain. If time is as crunched as you say and you use C4D constantly wouldn't it make more sense to get that punch up sorted out?

Cheers

Karl

Share this post


Link to post

I think I'll buy a new keyboard cause this one is not working anymore...

This one makes people misunderstand me... *sigh*

The solution you found is the exact same thing I meant, and I think I said that, but maybe my english is that bad...

[edit] and bytheway I am on a mac too... and I said make another shortcut, which is obviously a pc thing, but still... it's basically the same.. oh well... nevermind..

Share this post


Link to post

I understood doubledope and restated your same answer with a picture to help. Don't be sad. Repeat after me Happy Happy Joy Joy Happy Happy :)

Share this post


Link to post

"Happy Happy Joy Joy Happy Happy"

now we just wait...

Share this post


Link to post

Dumb question, but when installing R11 on a 64-bit Mac, do you specifically activate the 64-bit mode? Is the default 32? Either way, where is this option?

Thanks.

Share this post


Link to post
Guest samwich

Navigate to your CINEMA 4D.app, right click, get info, check or uncheck the box that says "Open in 32 bit mode"

Share this post


Link to post

Great. Thanks. I'm not in front of that machine, or I would try that. But, does that mean that the default mode for R11 (upon install) is 64?

Share this post


Link to post

No the default install is 32 bit -the box is ticked on install & you have to change it to get 64 bit.

Regards

Andy

Share this post


Link to post

Actually, I just checked, and mine is set for 64 based on the install. In the "get info" the box which says "enable 32bit" is unchecked.

Thanks.

Share this post


Link to post
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...