Jump to content

Archived

This topic is now archived and is closed to further replies.

Guest mentalblock

Particles falling through collider object

Recommended Posts

Guest mentalblock
  • Topic Author
  • I am trying to get a stream of emitted particles (spheres) to spin around inside a cylinder and then just land in the bottom. Currently they seem to be falling through the bottom even though both the cylinder and base are collider objects.

    I've tried combining them with a boolean but that doesn't seem to help either. Is there a way to stop them falling through ?

    Many thanks in advance.

    Gary.

    cylinder dynamic test.c4d

    Share this post


    Link to post

    Can you post a scene file? I wouldn't mind taking a look for you.

    Share this post


    Link to post

    Post a scene or screen shot of your setup. Much easier to understand and help.

    In order for the emitter to be seen as dynamic, you need to have it set upt in this order: Emitter --> Cloner --> Object(s)

    This will emit as many dynamic particles as your system can handle.

    Share this post


    Link to post

    In the collision tab of the cylinder, try changing the type from automatic to either static or moving mesh. That's worked for me before when trying to stop stuff falling through colliders.

    Share this post


    Link to post

    I did a little test for you. Cylinder, Sphere in a cloner in an emitter, dynamics tag added to cloner, collider tag added to cylinder, cylinder collision surface set to static mesh, document settings / dynamics / expert / Steps per frame set to 20 (which stops the occasional one falling through)...

    Is that the sort of thing ?

    Jay

    Share this post


    Link to post
    Guest mentalblock
  • Topic Author
  • Sorry I was convinced I uploaded a scene file last night. Guess I chose the file but didn't attach it to the post :signthankspin:

    File added now.

    Thanks for your help so far.

    Gary.

    Share this post


    Link to post

    Just increase your "steps per frame" (Edit>Project Settings>Dynamics>Expert)

    You may have to also adjust your collision margin in order to keep the particles close to the collision object. Keep in mind, the lower the collision margin, the more accurate the simulation will be BUT you will have to increase the Steps per Frame as the collision margin lowers, which will slow down viewport playback speed.

    Hope that helps some.

    Share this post


    Link to post
    Guest mentalblock
  • Topic Author
  • That's solved it. :signthankspin:

    I would never have found that on my own.

    Very Many Thanks

    Gary

    Share this post


    Link to post
    Guest
    This topic is now closed to further replies.

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×
    ×
    • Create New...