Jump to content

Archived

This topic is now archived and is closed to further replies.

aneirin

Multishader - First Clone Is Grey

Recommended Posts

  • Topic Author
  • I'm hoping this is just a simple mistake. i'm using multishader on some clones along a spline, no matter what I do the first clone is always grey. any ideas?

    Share this post


    Link to post

    Scene file please.

    3DKiwi

    Share this post


    Link to post
  • Topic Author
  • Author of the topic Posted

    here it is.

    while i was stripping the scene down I noticed that if you switch off the 1st sphere under the cloner it affects the 2nd one? not sure if this is related. looks like something is going wrong...

    multishader_example.zip

    Share this post


    Link to post
  • Topic Author
  • Author of the topic Posted

    after rendering I've just noticed that all the textures swap places half way through as well??

    this multishader is starting to look like more trouble than it's worth

    Share this post


    Link to post

    hy

    By changing the hierarchy under your cloner it was fixed

    i removed the null, and placed the 2nd sphere and tube under the 1st sphere,then put the multishader on the sphere.

    Voila

    i attached the fixed setup

    hope it helps

    multishader_example-Fix.zip

    Share this post


    Link to post
  • Topic Author
  • Author of the topic Posted

    brilliant thanks that fixed the grey clone, but the textures are still swapping places at frame 1 and 161

    Share this post


    Link to post

    hy

    happens to me as well with this file (also around f100)

    but couldn't figure out why - sorry

    Share this post


    Link to post
  • Topic Author
  • Author of the topic Posted

    thanks for trying anyway : )

    I've been asking around and I've been told it could be something to do with the cloner offset messing up the index ratio, but I have no idea what to do about it.

    I need to use this as a template for a few different versions so it will waste a lot of time if i have to texture them separately.

    Share this post


    Link to post

    ok

    i think i got it :thumbsup:

    i disabled the cloner's offset so it won't mess up the textures

    and used a spline deformer instead

    and it seems to work

    ofcourse you'll have to adjust the animation

    check the file to see the results

    hope it helped

    Gilbert

    multishader_example 2.zip

    Share this post


    Link to post
  • Topic Author
  • Author of the topic Posted

    Perfect!

    a thousand thank yous sir!

    Share this post


    Link to post
    Guest
    This topic is now closed to further replies.

    ×
    ×
    • Create New...

    IMPORTANT INFO:

    We are in the progress of finalising upgrade to Cafe 3.0. If you are experiencing issues, please change the default theme to Cafe 2.5 and thing’s should work again. We will notify everyone when we resolve all the issues.
     

    It would be also great if you could report any issue you might have on your side so we can fix them. :cowboypistol: