Jump to content
Info News:
  • Cafe 2.0 almost done!

Archived

This topic is now archived and is closed to further replies.

Varanid

Zbrush To C4D Displacement Woes

Recommended Posts

  • Topic Author
  • I need help figuring out why my Zbrush sculpt looks funky once I import into C4D (with GoZ)

    Here's a pic of the sculpt in Zbrush. The base is a very clean head mesh, all quads, good topology.

    The following 3 pics are renders in C4D, trying to get the model to look like what I created it ZB.

    At 100% strength with a height around .5, or 1 or 1.5 the model looks smoothed, the mouth is open,(should be closed) and all the fine detail is gone.

    Raising the height more, things get blown out, tons of artifacts show up, but you can at least see my ZB sculpt is in there

    underneath it all. No matter what I try, and can't dial in a displacement coming from ZB.

    I'm totally lost.

    Share this post


    Link to post
    Share on other sites

    Not a Zbrush user,but I remember that you have to set gamma to 1 in spd for maps that come from mudbox (that is in R11.5).

    Hope that helps...

    Cheers


    Free C4D trainings from MAXON professional on our youtube channel

     

    https://www.youtube.com/c4dcafe

    Share this post


    Link to post
    Share on other sites

    I did a quick test and it works flawlessly - I´m baffled! Could you describe your steps in ZBrush?

    EDIT: One thing though - head imported HUGE. I´ll scale it down and see if there´s a difference.

    EDIT2: Nope, same same. Did you scale your model or the map upon importing?

    Share this post


    Link to post
    Share on other sites

    Another thought: Do you have your model under a Hypernurb? How many subdivisions did you do in ZBrush? Make the subdivisions identical and see if that helps.

    Share this post


    Link to post
    Share on other sites

    Try exporting the model as an OBJ and importing it back in C4D using the Riptide plugin.


    ------------- Cheers, Hans.

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • OK, I'll play around a bit more.

    I created the displacement map in ZB with the 'create displacement' tab on the right. I didn't flip any switches there - just created the map. I then sent to C4D via GoZ. His clothing imported fine with no issues, so seems I'm just missing something. HN on or off yields same results.

    Hrjove, gamma doesn't help.

    Pit, I'll check the subdivisions vs ZB and see if that helps.

    Thanks for the input so far peeps.

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • Ahh! Clicked '32 bit' in the Zbrush displacement settings, exported again - bingo!

    Pit, the results you got are similar to what I was getting, which is minus the detail I added to the base mesh.

    Here's a C4D render of what it looks like now after changing that setting in ZB before exporting.

    Share this post


    Link to post
    Share on other sites

    Nope - I couldn´t get the details, as I did not have the displacement map you created. I made one myself - the 6 indentations along the cheek - and it worked as it should in16 bit. Glad you found a solution, but the problem hasn´t been pinned down/resolved yet.

    Share this post


    Link to post
    Share on other sites

    Can we have a look at the texture ? It's possible the detail simply isn't there because you weren't in the lowest geometry mode.

    Also note that it's possible the resolution of your texture simply is to small for the level of detail.

    One more thing, set the sampling mode from MIP to SAT (I find that Alias1 sharpens the image, not very good for bump maps)


    ------------- Cheers, Hans.

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • Can we have a look at the texture ? It's possible the detail simply isn't there because you weren't in the lowest geometry mode.

    Also note that it's possible the resolution of your texture simply is to small for the level of detail.

    One more thing, set the sampling mode from MIP to SAT (I find that Alias1 sharpens the image, not very good for bump maps)

    Thanks for the help.

    I just tried to post the whole scene file, but it's too large even zipped. Tried attaching just the .tif,

    no joy there either. Again though, flipping the 32bit switch in the ZB displacement setting solved the problem for me. If 16 should have worked just fine, I have no idea what the issue was.

    Thanks for the heads up regarding MIP/SAT as well

    Share this post


    Link to post
    Share on other sites

    Can we have a look at the texture ? It's possible the detail simply isn't there because you weren't in the lowest geometry mode.

    Also note that it's possible the resolution of your texture simply is to small for the level of detail.

    One more thing, set the sampling mode from MIP to SAT (I find that Alias1 sharpens the image, not very good for bump maps)

    Hi, sfBlackFox (long time no see - although I´m at the lounge frequently).

    Good solution solving thoughts, but ZBrush would warn you to go down to the lowest level of division before you´d be able to create the displacement map. It´s a 2K map - it should be sufficient for the subtle displacement going on here.

    I think it´s impossible to solve the problem without having the complete file or being able to look Varanid over the shoulder. 16 bit/32 bit shouldn´t be the problem, but I have no issue with being proven wrong. I´d like to see the flattened maps - is there a distinguish difference in tonal range?

    Jim, if you find the time a screenshot would suffice.

    Share this post


    Link to post
    Share on other sites
    Guest
    This topic is now closed to further replies.

    ×
    ×
    • Create New...