Jump to content

Archived

This topic is now archived and is closed to further replies.

pedroliveira

Another Mysterious Alpha Channel Problem

Recommended Posts

Guest dataflow

your scene is different then the OM you posted

Share this post


Link to post
Share on other sites

  • Topic Author
  • your scene is different then the OM you posted

    I mean other then the softboxes and camera right?

    Share this post


    Link to post
    Share on other sites
    Guest dataflow

    its the comp tags on the "World Controls"

    alpha is considered transparency (comp tags do)

    enable "Seen by Transparency"

    by the way im guessing because cant really check the scene without tex

    Share this post


    Link to post
    Share on other sites

    Could you save the project with assets (File -> Save project with assets) so I can get the scene working properly?

    Also, delete the GSG lights, because they are just taking up space and are not needed for this.

    I played around a touch and created a similar scene using a Googled image of a Glock 17 (I created the alpha in Photoshop separately). I can show you how to get a clean alpha from any photograph in Photoshop to make sure it's not a problem with the alpha channel itself.

    I think the problem might be with your Compositing tags, but I'm not sure. Check out the scene file I attached, that should work fine.

    But please don't use the image I used, because it's just Googled, so there might be a copyright issue.

    Edit: Like dataflow said, the problem probably is the compositing tag. You should enable Seen by transparency in the objects that are behind your plane to make them visible through the alpha layer.

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • Alright boys! I'm getting close. Sorry for the no texture.. I don't see that File > save project with assets , but i added the textures to this zip file.

    So I added the compositing tag and checked "seen by transparency" and it got close to it. So i'm thinking now it has something to do with how i setup my alpha channel?

    outlinesOnly.zip

    post-91538-0-85921000-1322579061_thumb.j

    Share this post


    Link to post
    Share on other sites

    Here, try this texture.

    I cleaned up the channels in Photoshop and made a new Photoshop .psd with an internal alpha in the proper channel hierarchy.

    Open the file and hit Shift R to check the alpha.

    Hope this helps you out! :)

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • Here, try this texture.

    I cleaned up the channels in Photoshop and made a new Photoshop .psd with an internal alpha in the proper channel hierarchy.

    Open the file and hit Shift R to check the alpha.

    Hope this helps you out! :oops:

    Man i definitely appreciate the help! Can't thank you enough.

    The lines aren't perfect (they are slightly dotted), but WAYYYY better then what i had!... thanks dude!!

    Share this post


    Link to post
    Share on other sites

    Yeah, no problem.

    Try upping your anti-aliasing. I got the best result at 2x2 by 8x8.

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • Yeah, no problem.

    Try upping your anti-aliasing. I got the best result at 2x2 by 8x8.

    man that helped a lot! I ended upping it to 16x16 by 16x16.. added a few render minutes but it make it a lot better!

    Thanks!

    Share this post


    Link to post
    Share on other sites
    Guest
    This topic is now closed to further replies.

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×
    ×
    • Create New...