Jump to content

Archived

This topic is now archived and is closed to further replies.

LockDown

"hide" Team Render Client?

Recommended Posts

  • Topic Author
  • So I was speaking with my boss about Team Render and he wants me to utilize it on our network to speed up our work flow.  The issue is, we don't really have a render farm, instead we are mostly personal computers that everyone in the building works on for other jobs outside of graphics. He wants me to setup the team render clients on each computer so that the people using the computer don't have to deal with starting it up or watching the GUI output information on the renders, instead being completely automated and in the background.

     

    I have looked into the options to do this, even attempting to convert the Team Render client to a windows service, but when done it does not allow me to connect to the client anymore, saying it is "Unreachable".  The only other option I have is setting up a hotkey that will "hide" the window when pressed, but I am weary of doing that since it would have to manually be done by the user in the morning when they start up, and would also teach them how to possibly use the process to hide non-work related material.  I would just rather have it start hidden, no gui, no log, no splash screen, just working in the background.

     

    Has anyone else run into this issue and anything that can be done to help?

    Share this post


    Link to post
    Share on other sites

  • Topic Author
  • I found out I can reduce the window down to a cmd console by attaching -nogui to the end of the startup shortcut, but I still need to figure out how to make the console not show.

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • Found a solution.  Kind of silly since it seems so easy now.  All I had to do was use the Windows 7 Task Scheduler.   It gives you the option of setting the task for a program to start on user login, and remain hidden after starting.  I just used it on two computers and both, when restarted, loaded Team Render without showing a GUI or console, and connected right up with the work system.

    Share this post


    Link to post
    Share on other sites

    Glad you figured it out. You may also want to go into the client preferences and limit the number of threads that can be used. That way the client computer can still be used without bogging down.

     

    3DKiwi

    Share this post


    Link to post
    Share on other sites
    Guest
    This topic is now closed to further replies.

    • Recently Browsing   0 members

      No registered users viewing this page.

    Latest Topics

    Latest Comments

    ×
    ×
    • Create New...