Jump to content

Archived

This topic is now archived and is closed to further replies.

Masterpie

large file optimization

Recommended Posts

11 hours ago, Masterpie said:

what do you mean by that - that area is too small - i should make the plane bigger or?...because i tried that and it's working the same

 

thank you for you support.....but,will i ask you too much if you can fix my file(test.1.c4d) and show me how it's working with textures

 

 

I already fixed your file , just made some materials with color instead of textures , it is the same ,you can just put any material and it will work perfectly , because it is replacing the entire object with its materials no matter how it is  , but I am too lazy to download the textures  here is download of the fixed file 

 

17 hours ago, maliohammad said:

in this file I made the objects deferent in shape so you can notice the change of the objects with the materials

what I mean the falloff area is too small is "your plane was too huge compared to the plain's effector falloff , falloff works if it covering a specified amount of the object (if there is 2 objects in the cloner , the falloff should cover around 50% or a little bit more )  otherwise it won't work 

just open the test.1.c4d to know what I mean :D

 

Share this post


Link to post
Share on other sites

  • Topic Author
  • i just tried your file with texture and it doesn't work...or perhaps i'm talking about something else hear...i wanted that the texture to change it's resolution just in the falloff area,but as i see -it's changing the entire texture 

    ...i used the same texture but you can try it with any texture you want,i don't know why is not working for me :confused:,i tried to change falloff size,but it's working the same -it's changing the entire area of the texture,at once

    that's why i said if you can make an example with texture....

    test.1 (2).c4d

    Share this post


    Link to post
    Share on other sites
    2 hours ago, Masterpie said:

    i just tried your file with texture and it doesn't work...or perhaps i'm talking about something else hear...i wanted that the texture to change it's resolution just in the falloff area,but as i see -it's changing the entire texture 

    ...i used the same texture but you can try it with any texture you want,i don't know why is not working for me :confused:,i tried to change falloff size,but it's working the same -it's changing the entire area of the texture,at once

    that's why i said if you can make an example with texture....

    test.1 (2).c4d

    the technique above has 2 value only : 0,1 so it means change or not change 

    oh , now I understood what did you mean , this is another story , create 2 materials , one with HQ texture , there other one with low res texture , enable the alpha channel in the HQ mat , put a "proximal" shader in the alpha channel , 

    then create new sphere (this will be the falloff controller ) , make it invisible in the renderer , and add a display tag to it , change its display mode to lines , and the style to isoparms , in the basics tab of the sphere , enable color and make it any color you want 

     

    open the proximal shader (in the HQ mat alpha channel ) and  change the value to the ones in the screenshot 

    change the falloff mode from step to another one if you want a smoother transition (then you will need to increase the intensity value up to some thing like 400% to maintain some  hardness )

    there is limitation of this technique : it won't give you real time preview , it works o only in render 

    may be some one will come up with another method to have same effect but with editor realtime preview :)

     

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • ok i tried it with the 2nd method but again i cannot get it work as it should

     

    9 hours ago, maliohammad said:

    open the proximal shader (in the HQ mat alpha channel ) and  change the value to the ones in the screenshot 

    what screenshot? do you mean these settings:

    9 hours ago, maliohammad said:

    change the falloff mode from step to another one if you want a smoother transition (then you will need to increase the intensity value up to some thing like 400% to maintain some  hardness )

    here is my test (again with the same texture) test 2.c4d (this is with different proximal shader settings as those in the images i have put it here)

    this is looking like something i wanted,only with a smoother transition test 2.jpg (you can see proximal shader settings in the right side)

    ...only that after i render it looks like this test 2_[render].jpg

     

    and (only if we can make it to work right :) ) can this proximal shader be linked to a camera,like with the plain effector?

    Share this post


    Link to post
    Share on other sites
    5 hours ago, Masterpie said:

    ok i tried it with the 2nd method but again i cannot get it work as it should

     

    what screenshot? do you mean these settings:

    here is my test (again with the same texture) test 2.c4d (this is with different proximal shader settings as those in the images i have put it here)

    this is looking like something i wanted,only with a smoother transition test 2.jpg (you can see proximal shader settings in the right side)

    ...only that after i render it looks like this test 2_[render].jpg

     

    and (only if we can make it to work right :) ) can this proximal shader be linked to a camera,like with the plain effector?

    sorry , forget to add the screenshot xd 

    now check it , 

    yes , you can link the sphere to the camera 

    and I don't know , why the render problem , change the settings to match up those in the screen shot , 

    fortunately   I found another technique , and I think it is better than the old one , and give editor realtime preview :D 

    check the scene file below , those are the main steps  :

    - rotate your plane 180 degree , so the back faces are in the front , 

    - add the HQ texture to plane and change the side from both to front 

    - add the LQ texture to plane and change the side from both to back 

    -add polyFx as a child of the plain 

    -select the polyFx and go to mograph effectors and add a plain effector

    - in the plain effector disable position and enable rotation and set R.H = 180

    - change the falloff shape of the plain effector to sphere ( or any one you like )

    - make the falloff strength = 0 ( if it is not 0 , you will get semi-rotated polygons which is very bad )

    - as you increase the poly count of the plain you will get smother transition 

    check the file below :D  

    Screen Shot 2016-06-23 at 2.42.42 AM.png

    texture converter .c4d

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • hey i tried your file(with my texture - obvious :) ) and this is the result

    Viewport texture converter.jpg ,you can see the low and high resolution in the viewport,but the LQ textures is rendered also as HQ

     

    Render   texture converter_[render].jpg

     

    and i tried also the previous method with the settings from your screenshot with Use Vertices and Use Edges  but the render result is the same....does it work for you?

    Share this post


    Link to post
    Share on other sites

    can you give me the textures ?
    because it renders perfectly in my pc 

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • i post the link here a few posts ago but here it is

    On 6/22/2016 at 5:45 AM, maliohammad said:

    it's around 4,5 mb so i have to uploaded somewhere because of the size limitation of 3 mb here

    ...beware that you have to write those code on the download page with capital letters

     

    ...and if it's working for you,i want to see the screenshots from your renders,if it's possible 

    and by the way here is the render from your file   texture converter .c4d  (with those noise textures which you made it)

    texture converter_[render].jpg 

     

    i don't see here high resolution vs low resolution

    Share this post


    Link to post
    Share on other sites

    ok , just loaded the Textures in this scene 

    2 hours ago, maliohammad said:

    and every thing worked great 

    put the low res tex in the red material 

    and the high res one in the green mat 

    and this a screenshot of the file in my pc :D

    Screen Shot 2016-06-23 at 9.02.04 PM.png

    Share this post


    Link to post
    Share on other sites

    ok , just loaded the Textures in this scene 

    2 hours ago, maliohammad said:

    and every thing worked great 

    put the low res tex in the red material 

    and the high res one in the green mat 

    and this a screenshot of the file in my pc :D

    Share this post


    Link to post
    Share on other sites

    ok , just loaded the Textures in this scene 

    2 hours ago, maliohammad said:

    and every thing worked great 

    put the low res tex in the red material 

    and the high res one in the green mat 

    and this a screenshot of the file in my pc :D

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  •  

    3 minutes ago, maliohammad said:

    and this a screenshot of the file in my pc :D

    Screen Shot 2016-06-23 at 9.02.04 PM.png

    yes but is this the render or just the viewport (without rendering) ?

    and i want  a smoother transition between LQ and HQ,quite indistinguishable ,is this possible?

    Share this post


    Link to post
    Share on other sites

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×
    ×
    • Create New...