Jump to content


C4D sometimes renders 8bit?

Recommended Posts

hellopaul    1

I've noticed that sometimes C4D seems to render (or say it's rendered) an 8 bit image, and sometimes a 32 bit image. I have read that C4D "always renders at 32 bit", and it's up to me whether I save it as an 8, 16, or 32 bit format. But sometimes, in the lower left corner of the Picture Viewer, it'll say, for example, "Size: 1920x1080, RGB (8 Bit)", which is clearly not 32 Bit. For example, I've just returned to a render I left running - a still frame that took over 2 hours - and it's saying 8 Bit. I've now tweaked some render settings (I changed the GI's Primary and Secondary methods, set an Interactive Render Region and copied that to the Render Settings' Output > Render Region) and set the render going again. It's now (while the render is progressing) saying "32 Bit". Ah - the render has just finished, and it's now changed to "8 Bit". What's going on?

I have other renders sitting in the History of the Picture Viewer which say "32 Bit". Yes, I've been tweaking render settings, but as far as I can find, there's nothing that says "render at x-bit"...or am I wrong?

Also, I've read many people saying that a C4D 32-bit render is, as a 32-bit image should be, a HDR image. But if I have a render with some over-exposed areas and take it into Photoshop (saved as a 32 bit PSD), and reduce the exposure (using the exposure slider), there is absolutely no detail in the over-exposed areas. This is clearly NOT an HDR image. Am I doing something wrong?

Share this post

Link to post
Share on other sites

WickedP    0

Hi hellopaul,

at the risk of posting this multiple times (I seem to be having troubles posting?) I'll try again, one last time!

Cinema's render engine will calculate data based on 32bit at render time. When the render is complete, the image is converted to the bit depth as selected in the render settings. See Render Settings->Save->Depth. What you describe seeing in the picture viewer sounds fairly normal. Just be mindful however, that image formats may also determine the final bit depth when they're saved to file (some formats won't save in 32bit for example).

Re HDRI images - 32bit renders are effectively the same thing. The issue regarding the sliders not providing more "detail" when you change exposure levels might be to do with your lighting, the bit depth of your render, or both. Take a look at the red-marked areas in the two attached images below, might help. The scene light's brightness is set to 1000%.

Exposure 1.jpg

Exposure 2.jpg

Kind regards,


Share this post

Link to post
Share on other sites
hellopaul    1
  • Topic Author
  • Thanks, WickedP.

    After I'd posted that question, I wondered if the "Save" section of the Render Settings would have an impact on the image, and, to my surprise, yes it did. I had no filename set in the the File... box, so C4D didn't save the images; they just sat in the History tab of the Picture Viewer, so I assumed that everything in the Save section had no effect. But having done a quick test, yes, as you say, the Depth does affect the colour depth that the rendered image is stored at, even while it's just sitting in RAM (or C4D's cache maybe), so if that's set to 8-bit, all that lovely HDR info is just thrown away. It's weird (and stupid) that this defaults to  8 Bit/Channel - I'm sure that must confuse many new users (although the concept of HDR and 32 bit might be even more confusing to some new users, who knows).

    I also did a very quick exposure test (a cube with a light at 1000% intensity), rendered it at 32-bit (looked completely white), and yes, I could bring back the detail reducing the exposure with the Filter tab and in Photoshop, exactly as your test shows. It's weird that I couldn't do this with some of the 32-bit renders I created yesterday...but I suspect I might have the answer - maybe some of my texture maps were only 8-bit - I'm guessing that might screw things up?

    (I've just checked, and yes, the textures on a person's white shirt, which was particularly over-exposed in yesterday's renders, are 8-bit PNGs, generated by the Mixamo website. I wonder if I just change the bit depth in Photoshop of these textures to 32-bit, if that would help? I'll probably just tweak my lighting instead for now, but worth considering for future projects).

    Share this post

    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    • Recently Browsing   0 members

      No registered users viewing this page.