Jump to content


This topic is now archived and is closed to further replies.


"Physical Sky" atmosphere - only 1km large ?

Recommended Posts

I am trying to properly set a landscape scene where camera moves from ground level up to something like 1km.

I need correct effect of the atmosphere on distant landscape (mountains) - I presume Physical Sky should be used in such situation.

However when I turn on atmosphere in physical sky, I get correct results only when camera is just above the ground level.

When camera goes above 100m, whole physical sky thing starts to looks completely unrealistic :

First we see a disc of thickening fog engulfing ground view,  beyond  ground  is not masked by atmospheric haze - you can see the horizon line.

Initially this "atmospheric disk" have about 1km radius  then it starts to grow and engulf more distant objects.

I can tinker with Physical Sky object scale, to make it larger, but it makes atmosphere thinner,  it is the same as making whole scene smaller (and instead of using real scale 1 km mountains at 5 km use  10 m tall mountains at 50m...)

Am I doing something stupid with Physical Sky, or is it just "Physical" by its name, and it can't properly cope with larger landscape scenes ( of natural world dimensions) ?

Below some pictures taken at various heights above the ground :












zzz atmop test.c4d

Share this post

Link to post

I too have run into this problem where you effectively 'run out' of atmosphere the higher you put the camera. I came to the conclusion that Physical Sky was designed for roughly ground level viewing only, so lowered my cam until it looked OK. As it happened I had to turn off atmosphere anyway as it produced annoying little black square artefacts randomly all over the rendered image. I don't think that feature has had any attention from Maxon since it first arrived !

Share this post

Link to post

I wonder if @HSrdelic can shed any light on this one ?

Share this post

Link to post

Dear !  It is quite bad !   I just give a try to e-on  Ozone PLE, but inside Vue it is even 10 x bigger disaster than Physical Sky.    e-on Vue copes pretty well with the same scene, but Ozone plugin inside C4D...  just LOL.  Anyway, I'll try to come with something from Physical Sky, and I will sent a message to Maxon about this issue.

Share this post

Link to post

Just had another thought on this. Is it possible that atmosphere does actually thin out as you get higher, ie in the real world and Physical Sky is simming that too ? That might explain this behaviour, though not make it any more useful to you of course...

Share this post

Link to post

I think that problem is in units.   When reading C4D manual  I found this :

Max. Distance [0..200000m]

Use this setting to optimize render times. Roughly speaking, this distance is calculated from the camera’s point of origin, looking into the scene (to be more precise: from the point where the environment object’s raytrace ray hits a transparent object).

Only the fog that lies within this range will be calculated. Assuming the camera is positioned just above the ground and is pointed towards the horizon: It would not make sense to calculate the fog at a distance of 100,000 m when it would already cover all objects lying beyond 10,000 m. In such a case, reduce this setting’s value.

200000m = 200km so this is a value that should be OK for most cases.

But what you get today In R18 ?     2 km  only !!!    The number remains the same 200000 bu now it is expressed in cm instead of meters.

Probably the same mistake cause the atmosphere to end at roughly 2km from camera and be only about 100m  thin -  mistake with units.

I am going to write a word to Maxon about it.



Share this post

Link to post

Mentioned above problem with Fog Max Distance maximum value 2000m cannot be overcome with scaling of Physical Sky object .

As it is expressed with real units (meters) it is 2000m, and impossible to set a higher value unless Maxon fixes this bug.

Now, the only solution to get proper fog  is to resize your scene so it does not exceed 2km from camera.

Please, check attached pictures - on the first one you can see the fog effect on original scene - fog effect is clamped at 2000m - obviously this is bad.

The second  picture depicts the same scene sized down 100x  so now 2000m is 20m , and now whole scene fits inside Fog Max distance.

Maxon guys, I hope you understand what is the problem, if something is not clear, please sent me a message, so we could discuss the issue in details.

Atmosphere Tester - Fog Original size of the scene.jpg

zz Atmosphere Tester - Fog Scene sized down 100x.jpg

C4D files.rar

Share this post

Link to post

Well, if in Project Settings Project Scale is set to 1 meter, then everything is OK with Physical Sky !  :)

The only problem then is that all stuff you add to the scene is way too big  Figure is 180m tall, cube is 100m and so on....

Share this post

Link to post

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...