Jump to content


Guest mfloscher

Hide joints while painting weight?

Recommended Posts

Guest mfloscher

hello!! how is everyone doing?

I'm currently painting the weights on some joints, but the joint itself is covering a lot of my object and therefore, making it a little difficult to see the final result.

Is there a way to hide the joint while painting the weights? 

I tried Display tag with 0% visibility, to no avail.

I need to see it Shaded so putting it in "Lines" is not something I want to do.

Thank you!

Share this post


Link to post
Share on other sites

Guest mfloscher
  • Topic Author
  • 1 minute ago, Cerbera said:

    Yes - just filter Joints in the viewport filter menu.

    CBR

    I still see it while painting :c 

    Share this post


    Link to post
    Share on other sites

    Yeah I suppose if you have the weight manager open, that might prevent the filter working, although I don't remember that being the case.

    What about setting a custom size for the joints ? Could you temporarily or otherwise make them small enough that they are no longer causing the problem , using the custom size controls ?

    Also, have you tried layers ? The normal workflow is to have all your joints on a separate layer from the geometry, so maybe hiding the joints layer would work with the WM open ?

    Share this post


    Link to post
    Share on other sites
    Guest mfloscher
  • Topic Author
  • 1 minute ago, Cerbera said:

    Yeah I suppose if you have the weight manager open, that might prevent the filter working, although I don't remember that being the case.

    What about setting a custom size for the joints ? Could you temporarily or otherwise make them small enough that they are no longer causing the problem , using the custom size controls ?

    how can I do that? so far I sort of solved it by changing to perspective view and painting around, but I wanna know more solutions in case I can't get away doing this

    Share this post


    Link to post
    Share on other sites

    Have you read the manual ? - it seems pointless me duplicating information that you already have. And the help is very good for joints.

    I suspect the best solution is what I said about layers.

    Share this post


    Link to post
    Share on other sites
    Guest mfloscher
  • Topic Author
  • 6 minutes ago, Cerbera said:

    Have you read the manual ? - it seems pointless me duplicating information that you already have. And the help is very good for joints.

    I suspect the best solution is what I said about layers.

    I did and I couldn't find it, maybe you're confused about what I'm asking.

    Share this post


    Link to post
    Share on other sites

    OK, except I do think I understand what you're asking.

    The answer to your question is in the Object page of the help for the Joint object. I'm looking at it now.

     

     

    Share this post


    Link to post
    Share on other sites

     

    2 hours ago, mfloscher said:

    I still see it while painting :c 

    With the joints turned off in the Filter menu while weight painting I do not see the joint, so not sure why you are?

    Dan

    joint invisable.jpg

    Share this post


    Link to post
    Share on other sites
    14 minutes ago, Rectro said:

     

    With the joints turned off in the Filter menu while weight painting I do not see the joint, so not sure why you are?

    Dan

    joint invisable.jpg

    Yeah, me neither ;)

    Share this post


    Link to post
    Share on other sites

    The Filter menu will not work on selected joints this effect will also happen on joints in a layer. If you want to "hide" them select all your joints in the OM and in the AM under Object > "Bone" change the Display from Standard to None...that way only the joint axis is displayed! If you want to hide the joint axis go to the next settingsgroup "Joint" and change the Display setting to None!

    Hope that helps.

    Share this post


    Link to post
    Share on other sites
    Guest mfloscher
  • Topic Author
  • 23 hours ago, nightlight said:

    The Filter menu will not work on selected joints this effect will also happen on joints in a layer. If you want to "hide" them select all your joints in the OM and in the AM under Object > "Bone" change the Display from Standard to None...that way only the joint axis is displayed! If you want to hide the joint axis go to the next settingsgroup "Joint" and change the Display setting to None!

    Hope that helps.

    thank you!

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×