Jump to content


Sign in to follow this  
zedreal

Alpha / Transparency

Recommended Posts

zedreal    0

Hi All,

 

I'm trying to transition between various liquid 'blobs' for a project. I've created a matt layer in After effects that has a turbulent feathered edge, but when I apply it to the alpha channel it goes hard edged, unless I turn off the transparency then it looks fine.

 

I've attached some images to demonstrate...

 

Image1 shows the hard edge problem I'm getting. If I turn off the transparency channel I get image 2, where the transition is correct but now I have no transparency / refraction.

Image 3 is the matt I've applied to the alpha channel.

 

I've tried every combination of 'soft, 'image alpha', pre-multiplied etc etc & nothing works.

 

I just want my alpha (Which is acting like a bool) to be subtle & feathered, not this horrible binary thing I have right now.

 

Any help or poiters would be greatly appreciated.

 

P

Screen Shot 2017-08-07 at 14.29.22.png

Screen Shot 2017-08-07 at 14.29.51.png

Screen Shot 2017-08-07 at 14.30.31.png

Share this post


Link to post
Share on other sites

bentraje    84

Is the image based on viewport or rendered in an image? If it is in viewport, you can trying setting a higher material quality in the "Editor" section of the Material. 

Share this post


Link to post
Share on other sites
zedreal    0
  • Topic Author
  • the renders are viewport, but the final rendered image is the same.

     

    Share this post


    Link to post
    Share on other sites
    MJohnny    32

    You want transparent material like glass and you are loading the transition into alpha?

    I would load it into transparency only. Try to simplify your material as much as possible.

    That way, it is easier for you to solve the problem.

    material.jpg

    Share this post


    Link to post
    Share on other sites
    zedreal    0
  • Topic Author
  • It seems to be the Absorption colour is the culprit. The colour was a kind of yellow/green, as soon as I made it white - it worked!

     

    But now my material looks odd.

     

     

    5989e1cd05398_ScreenShot2017-08-08at17_05_50.thumb.png.44659f239eea2e6704046be735f57c08.png

    Screen Shot 2017-08-08 at 17.07.04.png

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    Sign in to follow this  

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×