Jump to content
Sign in to follow this  
nerv

Tips and tricks for Redshift beginners

Recommended Posts

Let's throw a few tips and tricks in here for those getting started.  

 

First off: RENDER SETTINGS: 

 

A few findings from @Fastbee

Quote

I was testing Redshift more and ran into some things that I found speed up rendering by maybe 30%+ when combined.

 

1) Go to Render Settings > Redshift > Memory > Automatic Memory Management and check this on.  It takes more memory, but speeds up renders.

 

2) Render Settings > Redshift > System > Bucket Rendering and switch this to 256

 

3) When using Irradiance Point Cloud as the seconday GI Bounces, which seems to be the best option, change the Samples per Pixel under Irradiance Point Cloud settings to 1.  One one think this would lower the quality, but it doesn't.  It's really strange.  I have not tried it in a lot of scenes right now so if someone could re-verify this it would be great.

 

4) Under Unified Sampling setting it to 512 max and 256 min seems to be enough to get flicker free for even the hardest scenes.  Setting it higher does not seem to get any better quality for the extra time.  Setting it lower like 256 max 128 min can sometimes add to render time which I find strange.  Setting it very low can cause flickering in some scenes, so for previewing maybe ipr or using 16 max 4 min is good, but final rendering 512 max 256 min seems to be the best between no flickering and a fast render.  If flickering is still seen this should be upped at the cost of more render time.

 

I'll also add a couple of things I've learned can make your renders faster: 

 

Redshift's unified sampler definitely benefits from applying sampling overrides.  Allocating sample overrides prevents the unified sampler from getting overworked by trying to clean up stuff like reflections, refractions, etc.  So... 

 

 1) If using Brute Force for GI, take the ray count up to at least 2x your max unified samples.  So if you're doing 256/512, use at least 1024 for GI. 

 

2) Do the same for Individual overrides.  So, for the above, it's also recommended to try at least 1024 for lights, refraction, reflection, etc. as needed.  

 

This is some of what I've learned from Saul Espinoza's and Jesus Fernandez's tutorials on youtube.  They are Maya-based, but the same theories still apply and are quite helpful, even for C4D.  

 

Saul:

https://www.youtube.com/channel/UCUNokXBHp-7b_E6cDG4UA6A

 

Jesus:

https://www.youtube.com/channel/UCa0jeJu-5pm2W9wNDZeUBJg

 

 

 

ANOTHER ONE!

 

Never, ever trust progressive mode for your final render.  The IPR (when set to progressive) doesn't always show you what's going on.  For example, Multiple SSS is not visible in progressive mode.  Neither are caustics.  Also the IPR defaults to brute force mode, so any tweaks to GI will not be visible in progressive mode. 

 

So, if you're working with Multiple SSS, caustics, etc. and you can't really see what's happening, make sure you go to Redshift's render settings, and in the Basic tab, turn off "Force (progressive) Enabled for IPR."  This will take your IPR into bucket mode and show you everything exactly how your final render will come out.  

 

Of course, bucket mode will be slower than progressive, so you may need to turn down your unified sampler for relatively fast updates.  You can always switch back to progressive mode when you want to work more quickly.   

 

 

Share this post


Link to post
Share on other sites

  • Topic Author
  • AND ANOTHER ONE! 

     

    Ever wonder why your refractive materials look kind of weird by default? In order to be SUPER FAST, Redshift does a little bit of "cheating" and turns off certain things by default.  Sometimes you can get away with it, but other times, things can sometimes not look quite right.  This is especially true for refractive materials.  

     

    See how this glass cube renders by default: 

    shadowOpacity0-causticsOFF.thumb.jpg.c86b15a6445b84a578c793a133395994.jpg

     

    Not quite right, is it? 

     

    Let's see what happens when we turn on caustics: 

    shadowOpacity0-causticsON.thumb.jpg.20f9066596fa2938cd461dcd067b1279.jpg

     

    Better, but it still looks wrong.  There should still be some shadowing going on.  

     

    Go to your RSMaterial, and under Advanced > Refraction, turn up the Shadow Opacity - you may need to play around with the values to get the desired look.   

     

    Here it is with Shadow Opacity turned all the way up 1 and caustics turned off: 

    shadowOpacity1-causticsOFF.thumb.jpg.5f3f99ee483eb59d9c9fce3ffe9ab8ad.jpg

     

    Alright, we got the shadowing going on now, but we need to refine this.  

     

    Now turn your caustics back on and do a bit of tweaking: 

    shadowOpacity1-causticsON.thumb.jpg.9d0b8ca2d42f4a46fd1181a18ead32bb.jpg

     

     

    Ta-da!

     

     

     

     

     

    Share this post


    Link to post
    Share on other sites

    From what I can tell Redshift looks to the Unified sampling settings first.  If the max setting is 512 and Brute Force was set to 1 it would use the 512 setting to take up to a max of 512 samples where needed.  It pushes the Brute Force (BF) to 512 where needed even if BF was set to 1.  Now lets say the Brute Force for the first bounce is over the max Unified Sampling (US) with Brute Force at 1024 and max US to 512.  In this case it takes 1024 samples for the first light bounce and uses that when calculating the US which it takes up to 512 for everything else.  It's pretty smart of Redshift in that the direct lighting samples probably don't need as many samples as the primary bounce does.  The primary bounce is the most important for GI and is much harder to calculate than direct lighting.  Now one might say if my scene is only lit by indirect light I could leave the US at 1 and push the BF up really high to save render time.  It kind of works, but in my tests the US, like it's name implies, also seems to push a more unified sample over the image to eliminate blotches.  If BF was used at 1024 and US at 1 blotches could occur in animations.  The US also controls depth-of-field, motion blur, and anti-aliasing quality.

     

    In the Unified Sampling there is also Adaptive Error Threshold (AET).  "This parameter controls how sensitive the noise detection algorithm will be. Lower numbers will detect noise more aggressively which means that more rays will be shot per pixel and vice-versa. It is recommended that you use the ‘show samples’ feature to visualize the effect of this parameter. The default 0.01 value should work well for a variety of scenes. For production-quality results, we recommend lower settings such as 0.003."  AET seems to work amazingly well with it not taking much more processing power to figure out which pixel needs more samples.  Knowing this let's say we set US Min to 1 and Max to 512.  As said in the first post 512 seems to give the best quality for some odd reason and lower render times.  A higher US max does not seem to give better quality for some strange reason.  Now we set BF rays at 16384 it's max.  We do this because AET seems to also control BF samples.  The more BF samples the better.  Set Irradiance Point Cloud samples to 1.  The AET is so powerful we can now control exactly how fast Redshift renders and with what quality with the one parameter.  Doing it in this way makes AET into a single make it pretty slider.  Values between 0 and 2147483647 work for this with the higher number giving less quality and 0 being the max quality.  I found a value of 0.001 is the lowest it can go without being 0 and seems to be needed for some scenes.  A value of 0 gives the best results if one wants to wait much longer.  If doing animations a higher AET could be used with Randomize pattern every frame as the different samples can be smoothed between frames with great results.  Now that I know this I'm kind of scratching my head wondering why Redshift didn't simplify it to the one slider.  It really does work that well.

    Share this post


    Link to post
    Share on other sites

    Hi everyone, first I'm sorry for my bad english.

    I have a question about alpha texture overlay with redshift.

    I hope anybody can help me, attached here the file link.

    I have to put a alpha texture over another metals material bu not work like octane or c4d engine and I don't understand why.

    PLEASE HELP ME!!! :-)

    thank you very very MUCH

    Gio

     

    https://drive.google.com/open?id=1Pib9uXlQb6dd-1acdGbPUm-Qjzw-wsa6

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • You don’t stack redshift materials via the object manager. You have to do it using nodes. 

     

    See the thread below. 

     

    Share this post


    Link to post
    Share on other sites

    You are the best

    thank you very much

    Share this post


    Link to post
    Share on other sites

    Hy Guys sorry again...

    Is it possible after that work also with orange texture?

    I can work with base mayerial but non whit orange also...I mean roughness etc etc (sorry for my english :-((( )

    energy bar wip.jpg

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • The “plastic decal” node should be another RSMaterial node, with all of its own parameters, including roughness, etc. 

    Share this post


    Link to post
    Share on other sites
    Sign in to follow this  

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×
    ×
    • Create New...