Jump to content

M G

Regular Member
  • Content Count

    32
  • Joined

  • Last visited

Community Reputation

2 Noble Beginner

About M G

  • Rank
    Cafe Ronin

Profile Information

  • First Name
    M
  • Last Name
    G
  • C4D Version
    19.024 Student
  • Location
    City
  1. yes, I'm still figuring that stuff out...the rotations especially!
  2. Hi all, It's kind of odd but I think I try everything, start to write a reply stating it doesn't work, and as I'm writing the message and noting all the details I find some thing I missed and it works. This might be premature but I'm getting it to react at least and am closer.... For those using a slider with percentage to control (0-100): Node Properties: Input range: User Defined Output range: User defined Use Spline Parameter: Input lower - 0 Input Upper- 100 Output lower- Low end of range Output Upper- High end of range X axis (horizontal) - Represents slider from 0-100% Y axis (vertical) - Represents output range (0 is lower, 1 is upper) Thanks for all the input, much appreciated!
  3. Thanks Jed for explaining this! I found a tutorial as well that explains this but yours has better info. I think this should work for what I'm trying to do. Many thanks!!!
  4. Hi Cairyn, Thanks very much for the reply. I have not tried spline as a control with range mapper, mostly because I don't know how it works/have never used it. Does this mean I can make something like a bell curve as input for the range mapper? This would make sense, as I need the same value at start and end, but in between end points it slopes up and then back down. I'll look into it if this is the case. Is this the general idea? Thanks!
  5. Hello all, I'm using a slider (0-100%) in Xpresso for animating an object that rotates. If I use a constant (for argument's sake lets just say 50), the start and end location of rotation are good, but in the middle there is a dip, and the rotation lags (ie this is not a linear equation). I could keyframe and make up the difference, but things would get ugly quick. As an example what I want is the constant start at 50, then dip to 45 at 50% then go back to 50 at 100%. I'm generalizing here, it might require more inputs than in one place (at 50%), but I'd like that the variable to transition smoothly, but be tied to the slider and not to keyframes. Is there an equation I can use, or a way to have multiple variables based on the slider percentage and have them transition smoothly? There are other functions linked to the slider so it has to work with the % slider. I hope this makes sense, thanks for any suggestions!
  6. Hello, I have a project that has come back from being sidelined, and I was hoping someone might have an answer to my question. I've created a swept object using Mospline as the path. I've added an Effector (formula) of a sine wave to give the line a repetitive predictable motion (see attached file). What I'd like to do is attach an arrowhead on the end of the sweep, and have it move with the sweep (can't be done because it's not an editable object). I can fake it by giving it a side to side motion in time with the wave, but I'm wondering if anyone has other ideas. I'd like to figure a way to attach it to the sweep, or use the same formula so it can move in sync with the sweep. Open to any suggestions... Thanks! Align_arrowhead.c4d
  7. I'm going to give this a mini bump and add that I think the problem is in the sweep (the sweep is rotating, and that I need a rail spline or something like it to control the sweep rotation. From what I've read I need to duplicate my sweep path (spline) and use the duplicate as a rail. My question regarding this is if I animate my spline, can a duplicate of it still work as a rail? The rail works on static splines but I'm not sure if it will for an animated (dynamic) spline. If anyone has any experience with this kind of problem, and know a different solution or have a suggestion, please help! Thanks!!!
  8. For reference to this problem, I've attached a short animated file. It shows the spline rotating when the nulls are moved. My goal is to animate a curve (spline) with wave motion in a 2D plane (XY axis). To animate the curve I rigged it with nulls at the vertices, and animating the nulls on the XY axis. Because the nulls are moving in a planar manner/positionally, I have no idea why the spline is rotating. Maybe someone knows how to lock the spline on the XY axis to prevent rotation? Maybe my spline settings should be changed? Maybe I should rig everything in a different manner? Open to any suggestions. It seems like a very straightforward animation but I'm running into some odd issues. Thanks! curved wave_animation_01.c4d
  9. I think I'm posting questions too soon. I don't know if I solved this or not, but I decreased falloff in the Formula effector and increased parameter of wave heights and I got the wave to improve. For what I need this is good enough. My apologies for posting questions and answers to my own questions. Maybe someone can learn from them.
  10. Hello All, Not sure if this is the right place to post this question, but since I've been working with Mograph so far I'll post it here. I'm trying to generate a waveform (sine) along an animated curve, meaning the points on the spline are to be in motion while a waveform moves across the spline. The waveform doesn't have to be mathematically 'correct' it just has to be a consistent wave (ie it could be a 'fake' sine wave) throughout the curve. So far I can generate a sine wave on a straight line with equal segments, but when the segments (vertices) get moved and create a curve with segments of unequal lengths ('irregular' curves), the wave gets longer in portions and shorter in others. Is there a (simplish) way to maintain a standard wavelength on a dynamic 'irregular' curve? It doesn't have to be a true sine wave but just needs a constant and equal wave motion while the curve changes in length/shape. Any help much appreciated. Thanks!
  11. I figured it out, kind of, but could still use help... In the Formula parameters I had position (for wave) set to 50mm on Y. I changed it to X @50 (Y@0) and this seems to have fixed it. Why it would even work initially in the Y I'm not sure. And oddly, this doesn't work if the line is completely straight, you have to switch the X and Y values if you want to view it as a straight line. So as a straight line to see a Sine wave motion the Y parameter has to be the wave height. If the line is curved, animated with motion the X parameter represents the wave height. If someone knows a way that it can be both a straight line and a curved, animated line with a single wave parameter (Xor Y) please let me know. I might need to animate the line going from straight to curved while maintaining the Sine wave motion.
  12. Hi All, Seems as soon as I solve something a new issue pops up.... I have a spline with a sine wave motion on it (see attached file). I want to animate the spline at the vertex level as a secondary motion (or primary depending on how you look at it). The way I've rigged my spline is I can animate the vertex movement via the nulls. All motion will be in the front view on the XY axis, very 2 dimensional. I'm running into a problem where if I move a null (vertex) beyond a certain distance in the X axis, the spline and/or the sine wave rotates 90 degrees. As everything is planar, I have no idea why this is happening. Is there a way I can lock everything to the viewplane (XY axis) to prevent the rotation? The whole animation is going to take place in a planar view (XY axis) so I don't want any rotation. I thought this would be straightforward but maybe I'm missing something? As always, any ideas or help is greatly appreciated! Thanks!!! secondary_mospline_01.c4d
  13. Thank you to all who have given great ideas and input to this problem. I think I know what I'm doing now... Big thanks to Hrvoje for pointing me in the current direction (which he advised me to do since I started this project). I've attached a file that has the basic rig set up, now it just needs some refinement. I did this in R19 for anyone interested. To explain a little further, I want to animate my spline throughout the animation (and have it straight at some point) so the nulls are the vertices of my original spline and they will be animated. In my animation the strand will be going up, so I rotated the gravity 180 degrees. All the basic setup is there, just needs some tweaking (I hope!!!) to make it look a little nicer. My last question is, on the reference animation from 00:40 to 1:05 as the spline detachaes/attaches to the 'rungs' there's a little magnet effect happening at each rung. Any idea on how to add this effect? It's not absolutely needed (I imagine otherwise keyframing a stutter step) but it'd be nice to know how to do it. Check it out, let me know if you have any questions. And thanks again for all the help, this forum is amazing!!!! Strand01.c4d
  14. Thanks Deck for diving into this. I couldn't get the file to work either (I'm R19) but I do see what's going on with yours. It all looks like a simple animation but from where I sit it's not as simple as I thought it'd be...

Latest Topics

Latest Comments

×
×
  • Create New...